您的位置:首页 > 其它

二分——HDU1551:Cable master (精度控制)

2018-04-11 17:36 369 查看
题目:

Cable master


Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a “star” topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.

The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.

If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number “0.00” (without quotes).

Sample Input

4 11

8.02

7.43

4.57

5.39

Sample Output

2.00

AC代码:

#include <iostream>
#include <iomanip>
#include <cstdio>
#define eps 1e-6
using namespace std;
int N, K;
double a[10010];

int check (double X)
{
int i , s=0;
for (i = 0; i < N; i++)
s +=(int )(a[i]/X);
return s;
}

int main()
{
int i,t=100,m;
scanf("%d%d",&N,&K);

for (i = 0; i < N; i++)
{
scanf("%lf",&a[i]);
}

double st = 0, ed = 0x7ffffffff;

while (ed - st >eps)
{
double mid = (ed +st)/2;
if (check (mid) >= K)
st= mid;
else ed = mid;
}

m = (int)(ed * 100);
ed = (double)m/100;
printf("%.2lf\n",ed);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: