您的位置:首页 > 其它

HDU-3555 Bomb (数位dp 入门题)

2018-04-10 00:08 447 查看


Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 20547    Accepted Submission(s): 7696


Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would
add one point.

Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

 

Output

For each test case, output an integer indicating the final points of the power.

 

Sample Input

3
1
50
500

 

Sample Output

0
1
15

HintFrom 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.

#include <bits/stdc++.h>
using namespace std;
long long dp[29][10][2];
void init(){
memset(dp, 0, sizeof(dp));
for(int i = 0; i <= 9; ++i){
dp[1][i][0] = 1;
}
for(int i = 2; i <= 19; ++i){
for(int j = 0; j <= 9; ++j){
for(int k = 0; k <= 9; ++k){
if(j == 4 && k == 9){
dp[i][j][1] += dp[i - 1][k][0];
dp[i][j][1] += dp[i - 1][k][1];
}
else{
dp[i][j][0] += dp[i - 1][k][0];
dp[i][j][1] += dp[i - 1][k][1];
}
}
}
}
}
int main(){
init();
int T;
long long x;
scanf("%d", &T);
while(T--){
cin >> x;
x++;
vector<int>s;
while(x){
s.push_back(x % 10);
x /= 10;
}
int n = s.size() - 1;
long long ans = 0;
s.push_back(0);
int flag = 0;
for(int i = n; i >= 0; --i){
for(int j = 0; j < s[i]; ++j){
if(flag == 0) ans += dp[i + 1][j][1];
else ans += dp[i + 1][j][0] + dp[i + 1][j][1];
}
if(s[i] == 9 && s[i + 1] == 4) flag = 1;
}
printf("%I64d\n", ans);
}
return 0;
}

/*
题意:
1e18个数,问有多少个数的数位中包含连续的49。

思路:
数位dp,dp[i][j][0]表示最高位为第i位,且最高位为j时,数位中不包含49有多少种情况,
dp[i][j][1]表示最高位为第i位,且最高位为j时,数位中包含49有多少种情况。转移就很容
易写出来了。统计答案时注意如果已经出现49了,就不可以只统计包含49的情况。
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息