您的位置:首页 > Web前端

05-树8 File Transfer(25 分)

2018-04-04 19:45 411 查看
We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2≤N≤10

​4

​​ ), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2

where I stands for inputting a connection between c1 and c2; or

C c1 c2

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word “yes” or “no” if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line “The network is connected.” if there is a path between any pair of computers; or “There are k components.” where k is the number of connected components in this network.

Sample Input 1:

5

C 3 2

I 3 2

C 1 5

I 4 5

I 2 4

C 3 5

S

Sample Output 1:

no

no

yes

There are 2 components.

Sample Input 2:

5

C 3 2

I 3 2

C 1 5

I 4 5

I 2 4

C 3 5

I 1 3

C 1 5

S

Sample Output 2:

no

no

yes

yes

The network is connected.

思路:

并查集问题。依次处理命令,C开头的命令则执行check函数,检查两台电脑是否在一个集合,即是否有相同的根节点;I开头的命令则执行link函数,将两台电脑的集合合并为一个集合。

#include<stdio.h>
#define N 10001
int set_num;
struct computer{
int self;//自己的编号
int parentIndex;//父亲节点的下标,如果自身为根节点,则本变量的绝对值为所在集合的元素个数
}pc
;
void check(int i, int j, int n);
void link(int i, int j, int n);

int main(){
int n;
int a,b;
scanf("%d",&n);
//初始化pc
for(int i = 1; i <= n; i++){
pc[i].self = i;
pc[i].parentIndex = -1;
}
set_num = n;
while(1){
//show(n);
char enter;
scanf("%c",&enter);
char op;
scanf("%c",&op);
if(op == 'S')
break;
else if(op == 'C'){
scanf("%d%d",&a,&b);
check(a, b, n);//查询i,j连接情况,并输出结果
}else if(op == 'I'){
scanf("%d%d",&a,&b);
link(a, b, n);//把i、j所在集合取并集
}
}
if(set_num == 1){
printf("The network is connected.\n");
} else{
printf("There are %d components.\n",set_num);
}
return 0;
}

int findroot(int x, int n){
for(int i = x; i <= n;){
if(pc[i].parentIndex < 0)
return i;
i = pc[i].parentIndex;
}
return -1;
}
void check(int i, int j, int n){
if(findroot(i,n) == findroot(j,n)){
printf("yes\n");
}else{
printf("no\n");
}
return;
}
void link(int i, int j, int n){
int root1 = findroot(i,n);
int root2 = findroot(j,n);
if(root1 == root2){
return;
}else{
if(pc[root1].parentIndex < pc[root2].parentIndex){
//如果集合1中的元素多于集合2中的元素
pc[root1].parentIndex += pc[root2].parentIndex;
pc[root2].parentIndex = root1;
}else{
pc[root2].parentIndex += pc[root1].parentIndex;
pc[root1].parentIndex = root2;
}
set_num--;
}
return;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: