您的位置:首页 > 其它

杭电ACM 大数相加

2018-04-03 20:26 441 查看


A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 408641    Accepted Submission(s): 79199


[align=left]Problem Description[/align]I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
[align=left]Input[/align]The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
[align=left]Output[/align]For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
[align=left]Sample Input[/align]
2
1 2
112233445566778899 998877665544332211 
[align=left]Sample Output[/align]
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110 整体就是存储在字符数组里面,利用字符进行相加的一个过程。#include<bits/stdc++.h>using namespace std;
int main()
{
 char x[10002],y[10002],z[10002];
 int n,i,j,k,m,o;
 cin>>n;
 o=n;
 while(n--)
 {
  scanf("%s%s",x,y);
     i=strlen(x);
     j=strlen(y);
     for(k=0,m=0;i>0&&y>0;i--,j--)
     {
 
      m=m+x[i-1]-'0'+y[j-1]-'0';
      z[k++]=m%10+'0';
      m=m/10;
  }
  for(;i>0;i--)
  {   m=m+x[i-1]-'0';
   z[k++]=m%10+'0';
   m=m/10;
  }
  for(;j>0;j--)
  {   m=m+y[j-1]-'0';
   z[k++]=m%10+'0';
   m=m/10;
  }
  
  if(m>0)
    z[k++]=m%10+'0';
  printf("Case %d:\n%s + %s = ",o-n,x,y);
      for(;k>0;k--)
          cout<<z[k-1];
         cout<<endl;
     if(n)
       cout<<endl;
 }
 return 0;
}
[align=left]Author[/align]Ignatius.L
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: