您的位置:首页 > 其它

HDU 1164 Eddy's research I (质因子分解)

2018-04-03 14:49 316 查看

Eddy's research I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11390    Accepted Submission(s): 7057


[align=left]Problem Description[/align]Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

 
[align=left]Input[/align]The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
 
[align=left]Output[/align]You have to print a line in the output for each entry with the answer to the previous question.
 
[align=left]Sample Input[/align]
119412 [align=left]Sample Output[/align]
112*2*13*181
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
#define inf 65540
int vis[inf];
int mat[inf];
void prim()//素数打表
{
vis[0]=vis[1]=1;
int m=sqrt(inf+0.5);
for(int i=2;i<=m;i++)
{
if(!vis[i])
{
for(int j=i*i;j<=inf;j+=i)
{
vis[j]=1;
}
}
}
return ;
}
int main()
{
int n,m;
prim();
while(~scanf("%d",&n))
{
m=0;
memset(vis,0,sizeof(vis));
for(int i=2;i<=n;i++)
{
if(!vis[i]&&(n%i==0))//是素数且为因子
{
while(n%i==0)//看有多少个该因子
{
mat[m++]=i;
n/=i;
}
}
}
for(int i=0;i<m-1;i++)//输出
printf("%d*",mat[i]);
printf("%d\n",mat[m-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: