您的位置:首页 > 其它

HDU Problem q-dp

2018-04-02 20:33 162 查看
[align=left]Problem Description[/align]Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. <br><br>But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! <br> 
[align=left]Input[/align]The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. <br> 
[align=left]Output[/align]Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". <br>
[align=left]Sample Input[/align]
310 11021 130 5010 11021 150 301 6210 320 4
 
[align=left]Sample Output[/align]
The minimum amount of money in the piggy-bank is 60.The minimum amount of money in the piggy-bank is 100.This is impossible.
 
题意:小猪存钱罐,告诉你初始重量和最后存满的重量,求用最少多少钱把它存满
每种钱有不同的重量
思路:
完全背包求最小值的模板
第一行为测试数据量
下面一行为初始重量和最后重量
然后下面一行为有N种钱,每种钱有无数个
下面N行为钱的价值和重量
状态转移方程:
dp[j]=min(dp[j],dp[j-s[i].y]+s[i].x);
code:#include<iostream>
#include<cstring>
#define maxn 0x7ffffff//最大值
using namespace std;
struct Bag
{
int x;//类型
int y;//重量
}s[505];
int dp[10005];
int main()
{
int t;
cin>>t;
while(t--)
{
int e,p;
cin>>e>>p;
int m=p-e;
for(int i=1;i<=m;++i)
dp[i]=maxn;//定义为大数
dp[0]=0;//开始的为零
int n;
cin>>n;
for(int i=0;i<n;++i)
cin>>s[i].x>>s[i].y;
for(int i=0;i<n;++i)
{
for(int j=s[i].y;j<=m;++j)
dp[j]=min(dp[j],dp[j-s[i].y]+s[i].x);
//min 完全背包求最小值,dp=很大的数
//max 完全背包求最大值,dp=很小的数
}
if(dp[m]==maxn)//钱币的类型不能装满,不能组合重量后=m
cout<<"This is impossible."<<endl;
else
{
cout<<"The minimum amount of money in the piggy-bank is ";
cout<<dp[m]<<"."<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: