您的位置:首页 > 其它

POJ - 2955 Brackets 区间dp

2018-04-02 19:52 411 查看
题目链接
Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10528 Accepted: 5577
DescriptionWe give the following inductive definition of a “regular brackets” sequence:
the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:
(), [], (()), ()[], ()[()]

while the following character sequences are not:
(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.
Given the initial sequence 
([([]])]
, the longest regular brackets subsequence is 
[([])]
.
InputThe input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters 
(
)
[
, and 
]
; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.
OutputFor each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.
Sample Input((()))
()()()
([]])
)[)(
([][][)
endSample Output6
6
4
0
6SourceStanford Local 2004
给出一个 只有()[]的 字符串,问最多有多少括号能匹配(一对括号算2)
虽然看起来很像经典的堆栈应用,但是那个是判断是否完全匹配的,用于这个题目可能有实现难度(笔者没有什么头绪,可能有大神就是用堆栈做的)
首先笔者的解法为区间dp。
定义dp[i][j]为区间[i,j]的最大完全匹配数
那么对于dp[i][j]显然有 dp[i][j]=dp[i+1][j-1]+ matching(s[i],s[j])?2:0; 其中mathcing()为是否匹配
然后再进行状态转移就ok了
代码如下#include<iostream>
#include<string>
#include<cstring>
#include<vector>
#include<map>
#include<algorithm>
#include<queue>
#include<set>
#include<cstdio>
#include<functional>
#include<iomanip>
#include<cmath>
#include<stack>
using namespace std;
const int maxn = (int)(1e5) + 100;
const int inf = 0x3f3f3f3f;
const int mod = 2520;
const double eps = 1e-3;
typedef long long LL;
typedef unsigned long long ull;
int dp[111][111];
int main() {
//freopen("E:\\test.txt", "r", stdin);
char str[111];
while (~scanf("%s", str+1), str[1] != 'e') {
memset(dp, 0, sizeof(dp));
int n = strlen(str+1);
for (int len = 2; len <= n; len++) {
for (int i = 1; i <= n; i++) {
int j = i + len - 1;
if (j > n) continue;
if (str[i] == '('&&str[j] == ')' || str[i] == '['&&str[j] == ']') {
dp[i][j] = dp[i + 1][j - 1] + 2;
}
for (int k = i; k < j; k++) {
dp[i][j] = max(dp[i][j], dp[i][k] + dp[k+1][j]);
}
}
}
printf("%d\n", dp[1]
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 区间dp