您的位置:首页 > 编程语言 > C语言/C++

【HDU】1405 The Last Practice(分解质因数)

2018-04-02 16:25 295 查看
[align=left]Problem Description[/align]Tomorrow is contest day, Are you all ready?
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
what does this problem describe?
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.
 [align=left]Input[/align]Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it should not to be processed. [align=left]Output[/align]For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs. [align=left]Sample Input[/align]
60
12
-1[align=left]Sample Output[/align]
Case 1.
2 2 3 1 5 1

Case 2.
2 2 3 1
Hint
60=2^2*3^1*5^1

    简单来说,题意就是对合数进行分解,要注意输出格式。

代码:
#include <stdio.h>

int main() {
int
n;
int
num=1,count;
while (
scanf("%d",&n)!=EOF&&n>=0) {
if (
num!=1)
printf("\n");
printf("Case %d.\n",num);
num++;
count=0;
if (
n%2==0) {
while (
n%2==0) {
count++;
n=n/2;
}

printf("2 %d ",count);
}
for (int
i=3; i<=n; i+=2) {
count=0;
if ([/b]n%i==0){
printf("%d ",i);
while (
n%i==0) {
count++;
n=n/i;
}

printf("%d ",count);
}
}

printf("\n");
}
return
0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C语言