您的位置:首页 > 其它

Supermarket POJ - 1456 (堆)

2018-04-01 22:58 309 查看
A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.

For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4 50 2 10 1 20 2 30 1

7 20 1 2 1 10 3 100 2 8 2

5 20 50 10

Sample Output

80

185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

感觉我打过天梯发现自己的手速真的有问题,以前太过重想法轻实现,觉得手速也是一个非常重要的素质。说白了代码能力太弱了,应该正视这个问题才对。

今天还打了暴力杯,打之前不知道怎么就没睡着,既然睡不着就看一点算法有关的东西不是,起码可以利用点时间,到了5点,发现有点困了,但是9点就考试了,算了能睡一个小时就睡吧,定了7点半的闹钟。醒来感觉这样去打撑不过4个小时,起来以后吃完早饭,很自觉的买了一杯咖啡。幸好比赛的时候没有困意,注意力还是比较集中,到下午一点,打完以后瞬间就累瘫了,就超级困,超级想睡觉。睡到现在真是美滋滋…

思路:建一个小根堆,就是相当于用了c++的优先队列,但是莫名priority_queue就忘了怎么拼了。然后根据时间就是deadline来排序,来一个物品,就看他的时间和堆的大小比较,如果大于堆的size直接push,如果小于size和堆顶元素比较。如果大于,堆先pop再push。答案就是堆里的所有val的和。

代码

#include<iostream>
#include<cstdio>
#include<stack>
#include<algorithm>
#include<queue>
using namespace std;
struct node
{
int val;
int time;
}edge[10005];
bool cmp(node x1,node x2)
{
return x1.time<x2.time;
}
int main()
{
int n;
while(scanf("%d",&n)==1)
{
priority_queue<int, vector<int>, greater<int> >que;
for(int i=0;i<n;i++)
scanf("%d%d",&edge[i].val,&edge[i].time);
sort(edge,edge+n,cmp);
int ans=0;
for(int i=0;i<n;i++)
{
if(que.size()<edge[i].time)
que.push(edge[i].val),ans+=edge[i].val;
else
if(que.top()<edge[i].val)
{
ans-=que.top();
ans+=edge[i].val;
que.pop();
que.push(edge[i].val);
}
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: