您的位置:首页 > 其它

ZOJ Seven Segment Display(数位DP)

2018-04-01 22:29 483 查看
Seven Segment DisplayTime Limit: 2 Seconds      Memory Limit: 65536 KBA seven segment display, or seven segment indicator, is a form of electronic display device for displaying decimal numerals that is an alternative to the more complex dot matrix displays. Seven segment displays are widely used in digital clocks, electronic meters, basic calculators, and other electronic devices that display numerical information.Edward, a student in Marjar University, is studying the course "Logic and Computer Design Fundamentals" this semester. He bought an eight-digit seven segment display component to make a hexadecimal counter for his course project.In order to display a hexadecimal number, the seven segment display component needs to consume some electrical energy. The total energy cost for display a hexadecimal number on the component is the sum of the energy cost for displaying each digit of the number. Edward found the following table on the Internet, which describes the energy cost for display each kind of digit.
DigitEnergy Cost
(units/s)
06
12
25
35
44
55
66
73
DigitEnergy Cost
(units/s)
87
96
A6
B5
C4
D5
E5
F4
















For example, in order to display the hexadecimal number "5A8BEF67" on the component for one second, 5 + 6 + 7 + 5 + 5 + 4 + 6 + 3 = 41 units of energy will be consumed.Edward's hexadecimal counter works as follows:The counter will only work for n seconds. After n seconds the counter will stop displaying.
At the beginning of the 1st second, the counter will begin to display a previously configured eight-digit hexadecimal number m.
At the end of the i-th second (1 ≤ i < n), the number displayed will be increased by 1. If the number displayed will be larger than the hexadecimal number "FFFFFFFF" after increasing, the counter will set the number to 0 and continue displaying.
Given n and m, Edward is interested in the total units of energy consumed by the seven segment display component. Can you help him by working out this problem?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 105), indicating the number of test cases. For each test case:The first and only line contains an integer n (1 ≤ n ≤ 109) and a capitalized eight-digit hexadecimal number m (00000000 ≤ m ≤ FFFFFFFF), their meanings are described above.We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each test case output one line, indicating the total units of energy consumed by the eight-digit seven segment display component.

Sample Input

3
5 89ABCDEF
3 FFFFFFFF
7 00000000

Sample Output

208
124
327

Hint

For the first test case, the counter will display 5 hexadecimal numbers (89ABCDEF, 89ABCDF0, 89ABCDF1, 89ABCDF2, 89ABCDF3) in 5 seconds. The total units of energy cost is (7 + 6 + 6 + 5 + 4 + 5 + 5 + 4) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 6) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 2) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 5) + (7 + 6 + 6 + 5 + 4 + 5 + 4 + 5) = 208.For the second test case, the counter will display 3 hexadecimal numbers (FFFFFFFF, 00000000, 00000001) in 3 seconds. The total units of energy cost is (4 + 4 + 4 + 4 + 4 + 4 + 4 + 4) + (6 + 6 + 6 + 6 + 6 + 6 + 6 + 6) + (6 + 6 + 6 + 6 + 6 + 6 + 6 + 2) = 124.
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long ll;
const ll mod=(ll)0x100000000;
const int INF=0x3f3f3f3f;
const int maxn=25;
char s[10];
int t, n;
int val[16]={6,2,5,5,4,5,6,3,7,6,6,5,4,5,5,4}, wei[10];
ll dp[10][10000];

ll getnum(char* str){
ll sum=0;
for(int i=0; i<8; i++)
{
int tmp;
if(str[i]>='0' && str[i]<='9') tmp=str[i]-'0';
else tmp=str[i]-'A'+10;
wei[7-i]=tmp;
sum=sum*16+tmp;
}
return sum;
}

ll dfs(int pos, ll sum, bool limit){
if(pos==-1) return sum;
if(!limit && dp[pos][sum]!=-1) return dp[pos][sum];

int up=limit ? wei[pos] : 15;
ll ans=0;
for(int i=0; i<=up; i++)
{
ans+=dfs(pos-1, sum+val[i], limit&&(i==wei[pos]));
}

return limit ? ans:dp[pos][sum]=ans;
}

ll solve(ll x){
if(x==-1) return 0;

for(int i=0; i<=7; i++)
{
wei[i]=x%16;
x/=16;
}

return dfs(7, 0, true);

}

int main(){
scanf("%d", &t);
memset(dp, -1, sizeof(dp));
while(t--){
scanf("%d %s", &n, &s);
ll l=getnum(s);

if(l+n-1<mod)
{
ll r=l+n-1;
printf("%lld\n", solve(r)-solve(l-1));
}
else{
ll r=(l+n-1)%mod;
printf("%lld\n", solve((ll)0xffffffff)-(solve(l-1)-solve(r)));
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: