您的位置:首页 > 编程语言 > Go语言

【HDU】1397 Goldbach's Conjecture

2018-04-01 19:09 393 查看
[align=left]Problem Description[/align]Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2. 
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.
 [align=left]Input[/align]An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.
 [align=left]Output[/align]Each output line should contain an integer number. No other characters should appear in the output.
 [align=left]Sample Input[/align]
6
10
12
0 [align=left]Sample Output[/align]
1
2
1
    这道题考察了素数的判别,函数定义、调用

    这道题两遍AC,第一遍同样是因为超时。

代码:#include <stdio.h>
int a[40000];
int isPrime(int n)            //判断是不是素数的函数
{
int i;
for (i=2; i*i<=n; i++) {
if (n%i==0)
return 0;
}
return 1;
}

void Prime()            //求2到32768中所有素数的函数
{
int i;
for (i=2; i<=32768; i++) {
if(isPrime(i)==1)
a[i]=1;
else
a[i]=0;
}
}
int main() {
Prime();
int n;
while (scanf("%d",&n)!=EOF&&n!=0) {
int num=0;
for (int i=2; i<=n/2; i++) {        //从2到n/2循环寻找
if (a[i]&&a[n-i])
num++;
}
printf("%d\n",num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C语言