您的位置:首页 > 其它

贪心策略 CSU - 1722 Race(田忌赛马)

2018-04-01 00:02 274 查看

Description

Johnson and Bob are crazy motorcycle collecting enthusiasts. In order to prove their own motorcycles is the best, they issued a challenge to each other. Johnson wants to win the challenge.As a good friend of Johnson’s, you need to give advice to Johnson. Johnson and Bob each can select their best n motorcycles. And each motorcycle has a value v. There are n matches in total. Any motorcycle can be chosen optionally to participate in the match(but each motorcycle can only participate once). Each time the motorcycle with high value will win. Johnson gets the order of Bob’s motorcycles in advance. Can you help Johnson arrange the competition order of motorcycles in order to win the most of the matches?

Input

First line input an integer T(mean there are T cases)
In each case , first line input an integer n (mean there are n motorcycles) (0<n<=10000)
Next line input n integers (mean the value of Johnson’s n motorcycles)
Next line n integers (mean the value of Bob’s n motorcycles )

Output

Every case output an integer mean the most match can win.

Sample Input

1
5
6 4 5 1 3
8 9 3 4 7

Sample Output

2
代码:
#include <iostream>
#include <algorithm>
using namespace std;

int main(){
int T,n,J[10000],B[10000];
cin>>T;

while(T--){
cin>>n;

for(int j=0;j<n;j++){
cin>>J[j];
}
sort(J,J+n);

for(int b=0;b<n;b++){
cin>>B[b];
}
sort(B,B+n);

int loc=0;
for(int j=0;j<n;j++){
if(J[j]>B[loc]){
loc++;
}
}
cout<<loc<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: