您的位置:首页 > 其它

HDU Problem E [ 最长下降子序列 堆箱子]——基础dp模板题变式

2018-03-29 23:10 417 查看

Problem E

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)Total Submission(s) : 9   Accepted Submission(s) : 5[align=left]Problem Description[/align]A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.<br><br>The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. <br><br>They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. <br><br>Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.<br> 
[align=left]Input[/align]The input file will contain one or more test cases. The first line of each test case contains an integer n,<br>representing the number of different blocks in th
4000
e following data set. The maximum value for n is 30.<br>Each of the next n lines contains three integers representing the values xi, yi and zi.<br>Input is terminated by a value of zero (0) for n.<br> 
[align=left]Output[/align]For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".<br> 
[align=left]Sample Input[/align]
110 20 3026 8 105 5 571 1 12 2 23 3 34 4 45 5 56 6 67 7 7531 41 5926 53 5897 93 2384 62 6433 83 270 
[align=left]Sample Output[/align]
Case 1: maximum height = 40Case 2: maximum height = 21Case 3: maximum height = 28Case 4: maximum height = 342 =========================================         首先还是那句话,想AC,得先看懂题目。。。。。。

         题目大意:给出几种具有不同长宽高的长方体无数个,将它们堆叠起来,长方体可以“任意”方式摆放,但必须满足上面的长宽小于下面长方体的长宽,问能够堆叠的最大高度。

        思路:将各种箱子按长度降序排列,然后寻找宽度的最长下降子序列。。。。。。

        注意点:每种箱子可以有6种摆放方式,输入n之后n=n*6;(暴力解法)

AC代码:#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
struct block
{
int length,wide,high;
}a[201];
int f[201];
bool complare(block x,block y)
{
if(x.length==y.length)return x.wide>y.wide;//可以有一个量相同;
return x.length>y.length;
}
int main()
{
int n;
int k=1;
while(cin>>n&&n)
{
n*=6;
int ans=0;
memset(f,0,sizeof(f));
memset(a,0,sizeof(a));
for(int i=1;i<=n;i+=6)
{
cin>>a[i].length>>a[i].wide>>a[i].high;
a[i+1].length=a[i].wide;//呃。。。写的暴力点;
a[i+1].wide=a[i].high;
a[i+1].high=a[i].length;
a[i+2].length=a[i].high;
a[i+2].wide=a[i].length;
a[i+2].high=a[i].wide;
    a[i+3].length=a[i].length;
    a[i+3].wide=a[i].high;
    a[i+3].high=a[i].wide;
    a[i+4].length=a[i+1].length;
    a[i+4].high=a[i+1].wide;
    a[i+4].wide=a[i+1].high;
    a[i+5].length=a[i+2].length;
    a[i+5].wide=a[i+2].high;
    a[i+5].high=a[i+2].wide;
}
sort(a+1,a+1+n,complare);
for(int i=1;i<=n;++i)
{
f[i]=a[i].high;
for(int j=1;j<i;++j)
{
if(a[i].wide<a[j].wide&&a[i].length<a[j].length)f[i]=max(f[i],f[j]+a[i].high);
if(ans<f[i])ans=f[i];
}
}
cout<<"Case "<<k<<": maximum height = "<<ans<<endl;
k++;
}
return 0;

}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: