您的位置:首页 > 其它

POJ 1159 Palindrome 【LCS优化】

2018-03-29 21:21 344 查看
Palindrome

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 65828 Accepted: 22919
Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order
to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters
from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input
5
Ab3bd

Sample Output
2

#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
#define mms(x, y) memset(x, y, sizeof x)
#define MAX 5005
char a[MAX], b[MAX];
int dp[2][MAX];
int main()
{
int n;
while(scanf("%d", &n) != EOF)
{
scanf("%s", a);
for(int i = 0; i < n; i++)
b[i] = a[n - 1 - i];
int t = 0;
mms(dp, 0);
for(int i = 0; i < n; i++)
{
for(int j = 0; j < n; j++)
{
if(a[i] == b[j])
dp[t ^ 1][j + 1] = dp[t][j] + 1;
else
dp[t ^ 1][j + 1] = max(dp[t ^ 1][j], dp[t][j + 1]);
}
t ^= 1;
}
printf("%d\n", n - dp[t]
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: