您的位置:首页 > 其它

hdu 3294 马拉车算法

2018-03-29 09:05 155 查看
One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps:
First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……, 'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.
Input
Input contains multiple cases.
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase.
If the length of string is len, it is marked from 0 to len-1.
Output
Please execute the operation following the two steps.
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!".
If there are several answers available, please choose the string which first appears.
Sample Input
b babd
a abcd
Sample Output
0 2
aza
No solution!
 卡点卡的一笔, 多用了两次strlen(str),就tle了、#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>
using namespace std;
#define maxn 211111

int p[maxn<<1];
char str[maxn<<1];
char s[maxn];
char ch[3];

int f (int x) {
return (x-1)>>1;
}

int manachar () {
int n = strlen (s), l = 0;
str[l++] = '@';
str[l++] = '#';
for (int i = 0; i < n; i++) {
str[l++] = s[i];
str[l++] = '#';
}
str[l] = 0;
int r = 0, id = 0, len = 0;
for (int i = 1; i < strlen(str); i++)
{
if (r > i)
{
p[i] = min (p[2*id-i], r-i);
}
else
p[i] = 1;
while (str[i+p[i]] == str[i-p[i]])
p[i]++;
// len= max(len, p[i]);
if(len<p[i]-1)
{
len=p[i]-1;
}
if (p[i]+i > r)
{
r = p[i]+i;
id = i;
}
}
if (len == 1)
{
printf ("No solution!\n");
return 0;
}
for (int i = 1; i < strlen(str); i++)
{
if (p[i]-1 == len)
{
printf ("%d %d\n", f(i-p[i]+2), f(i+p[i]-2));
for (int j = i-p[i]+1; j <= i+p[i]-1; j++)
if (str[j] != '#')
{
printf ("%c", 'a'+(str[j]-ch[0]+26)%26);
}
puts("");
return 0;
}
}
return 0;
}

int main () {
//freopen ("in.txt", "r", stdin);
while (scanf ("%s%s", ch, s)!=EOF) {
manachar ();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: