您的位置:首页 > 其它

zoj 3954 Seven-Segment Display

2018-03-28 16:00 435 查看
A seven segment display, or seven segment indicator, is a form of electronic display device for displaying decimal numerals that is an alternative to the more complex dot matrix displays. Seven segment displays are widely used in digital clocks, electronic meters, basic calculators, and other electronic devices that display numerical information.

The segments of a seven segment display are arranged as a rectangle of two vertical segments on each side with one horizontal segment on the top, middle, and bottom. If we refer the segments as the letters from a to g, it’s possible to use the status of the segments which is called a seven segment code to represent a number. A standard combination of the seven segment codes is shown below.

X

a b c d e f g

1 1 0 0 1 1 1 1

2 0 0 1 0 0 1 0

3 0 0 0 0 1 1 0

4 1 0 0 1 1 0 0

5 0 1 0 0 1 0 0

6 0 1 0 0 0 0 0

7 0 0 0 1 1 1 1

8 0 0 0 0 0 0 0

9 0 0 0 0 1 0 0

0 = on 1 = off

A seven segment code of permutation p is a set of seven segment code derived from the standard code by rearranging the bits into the order indicated by p. For example, the seven segment codes of permutation “gbedcfa” which is derived from the standard code by exchanging the bits represented by “a” and “g”, and by exchanging the bits represented by “c” and “e”, is listed as follows.

X

g b e d c f a

1 1 0 1 1 0 1 1

2 0 0 0 0 1 1 0

3 0 0 1 0 0 1 0

4 0 0 1 1 0 0 1

5 0 1 1 0 0 0 0

6 0 1 0 0 0 0 0

7 1 0 1 1 0 1 0

8 0 0 0 0 0 0 0

9 0 0 1 0 0 0 0

We indicate the seven segment code of permutation p representing number x as cp, x. For example cabcdefg,7 = 0001111, and cgbedcfa,7 = 1011010.

Given n seven segment codes s1, s2, … , sn and the numbers x1, x2, … , xn each of them represents, can you find a permutation p, so that for all 1 ≤ i ≤ n, si = cp, xi holds?

Input

The first line of the input is an integer T (1 ≤ T ≤ 105), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains an integer n (1 ≤ n ≤ 9), indicating the number of seven segment codes.

For the next n lines, the i-th line contains a number xi (1 ≤ xi ≤ 9) and a seven segment code si (|si| = 7), their meanings are described above.

It is guaranteed that ∀ 1 ≤ i < j ≤ n, xi ≠ xj holds for each test case.

Output

For each test case, output “YES” (without the quotes) if the permutation p exists. Otherwise output “NO” (without the quotes).

Sample Input

3

9

1 1001111

2 0010010

3 0000110

4 1001100

5 0100100

6 0100000

7 0001111

8 0000000

9 0000100

2

1 1001111

7 1010011

2

7 0101011

1 1101011

Sample Output

YES

NO

YES

Hint

For the first test case, it is a standard combination of the seven segment codes.

For the second test case, we can easily discover that the permutation p does not exist, as three in seven bits are different between the seven segment codes of 1 and 7.

For the third test case, p = agbfced.

https://blog.csdn.net/loy_184548/article/details/69945431

这个博客对于算法讲的特别清楚,不过用的是数字版本,代码实现比较复杂。

字符串版本:

#include <bits/stdc++.h>
using namespace std;
<
4000
span class="hljs-built_in">string p[10];
void init()
{
p[1] = "1001111"; p[2] = "0010010"; p[3] = "0000110";
p[4] = "1001100"; p[5] = "0100100"; p[6] = "0100000";
p[7] = "0001111"; p[8] = "0000000"; p[9] = "0000100";
}
int main(void)
{
init();
int q;
scanf("%d", &q);
string a[10], b[10];
string s[10];
while (q--)
{
int n;
scanf("%d", &n);
int i, j;
for (i = 1; i < 10; i++)
{
s[i].clear();
}
int id; char str[10];
for (i = 0; i < n; i++)
{
scanf("%d%s", &id, str);
s[id] = str;
}
for (i = 0; i < 7; i++)
{
a[i].clear(); b[i].clear();
for (j = 1; j <= 9; j++)
{
if (s[j] != "")
{
a[i] += s[j][i];
b[i] += p[j][i];
}
}
}
sort(a, a + 7); sort(b, b + 7);
bool flag = true;
for (i = 0; i < 7; i++)
{
if (a[i] != b[i])
{
flag = false;
break;
}
}
if (!flag) printf("NO\n");
else printf("YES\n");
}
}


题目的难点还是在于抓住问题的本质。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: