您的位置:首页 > 其它

ZOJ 1114-Chocolate (概率DP)

2018-03-26 19:00 357 查看

Problem Description

In 2100, ACM chocolate will be one of the favorite foods in the world.
"Green, orange, brown, red…", colorful sugar-coated shell maybe is the most attractive feature of ACM chocolate. How many colors have you ever seen? Nowadays, it's said that the ACM chooses from a palette of twenty-four colors to paint their delicious candy bits.

One day, Sandy played a game on a big package of ACM chocolates which contains five colors (green, orange, brown, red and yellow). Each time he took one chocolate from the package and placed it on the table. If there were two chocolates of the same color on the table, he ate both of them. He found a quite interesting thing that in most of the time there were always 2 or 3 chocolates on the table.
Now, here comes the problem, if there are C colors of ACM chocolates in the package (colors are distributed evenly), after N chocolates are taken from the package, what's the probability that there is exactly M chocolates on the table? Would you please write a program to figure it out?



Input

The input file for this problem contains several test cases, one per line.

For each case, there are three non-negative integers: C (C <= 100), N and M (N, M <= 1000000).

The input is terminated by a line containing a single zero.



Output

The output should be one real number per line, shows the probability for each case, round to three decimal places.



Sample Input

5 100 20



Sample Output

0.625



Source

2002 ACM/ICPC Beijing 
给你c,n,m,表示有c种颜色的巧克力,每种颜色的巧克力有无数个,每次随机取一个放在桌子上,当有两个巧克力的颜色相同的话就会将这两个巧克力吃掉,问你在取n个巧克力后,桌子上正好有m个巧克力的概率是多少?
题解:设dp[i][j]:表示取完i个桌子上能留下j个的概率,然后直接进行dp即可,因为颜色数只有100这么大,所以当取的个数足够多时,概率会趋近于一个极限值,因此我们让n在很大时取一个合适的值即可。#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
double f[1005][105];
int n,m,c;
int main(void)
{
while(scanf("%d",&c),c!=0)
{
scanf("%d%d",&n,&m);
if(n==0 && m==0)
{
printf("1.000\n");
continue;
}
if(m>c || m>n || (n+m)%2)
{
printf("0.000\n");
continue;
}
if(n>1000) n=1000+(n%2!=0);
memset(f,0,sizeof(f));f[1][1]=1;
for(int i=2;i<=n;i++)
for(int j=0;j<=min(i,c);j++)
{
if(i+j&1)
{
f[i][j]=0;
continue;
}
if(j>0) f[i][j]+=f[i-1][j-1]*(1-(double)(j-1)/c);
if(j<i) f[i][j]+=f[i-1][j+1]*((double)(j+1)/c);
}
printf("%.3f\n",f
[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: