您的位置:首页 > 其它

HDU——1171 Big event in HDU(母函数)

2018-03-25 20:37 357 查看

Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don’t know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 – the total number of different facilities). The next N lines contain an integer V (0

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2

10 1

20 1

3

10 1

20 2

30 1

-1

Sample Output

20 10

40 40

解题思路:

可以使用背包算法写,基于上一条题目做的母函数题,发现母函数真的太好用了,就用母函数写了。顺便练习一下母函数。

代码:

//可以使用母函数 , 也可以使用背包算法
//母函数 和 背包算法在某种程度上是可以相互转化的
#include <stdio.h>
#include <string.h>
using namespace std;

int value[55];
int num[55] ;

int main(){
int n , i , j , k ,sum ,half ,*ways , *temp;
while(scanf("%d",&n) != EOF){
if(n < 0)
break;

sum = 0;
for(i = 1 ; i <= n ; i++){
scanf("%d %d",&value[i], &num[i]);
sum = sum + value[i] * num[i];
}

temp = new int[sum + 10];
ways = new int[sum + 10];

for(i = 0 ; i <= sum ; i ++){
ways[i] = 0;
temp[i] = 0;
}

half = sum / 2;

for(i = 0 ; i
4000
<= half ; i = i + value[1])
ways[i] = 1;

for(i = 2 ; i <= n ; i ++){
for(j = 0 ; j <= half ; j ++){
for(k = 0 ; k + j <= half && k <= value[i] * num[i]; k = k + value[i]){
temp[j + k] = temp[j + k] + ways[j];
}
}

for(j = 0 ; j <= half ; j ++){
ways[j] = temp[j];
temp[j] = 0;
}
}

for(i = half ; i >= 0 ; i --)
if(ways[i] != 0){   //不等于0 ,说明可以获取到当前的值
printf("%d %d\n",sum-i , i);
break;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: