您的位置:首页 > 其它

Problem E: 平面上的点和线——Point类、Line类 (V)

2018-03-24 17:36 357 查看

Problem E: 平面上的点和线——Point类、Line类 (V)

Time Limit: 1 Sec  Memory Limit:
128 MB
Submit: 5972  Solved: 2911

[Submit][Status][Web
Board]

Description

在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定,两点确定一条线段。现在我们封装一个“Point类”和“Line类”来实现平面上的点的操作。
根据“append.cc”,完成Point类和Line类的构造方法和show()方法,输出各Line对象和Point对象的构造和析构次序。
接口描述:
Point::show()方法:按格式输出Point对象。
Line::show()方法:按格式输出Line对象。
Line::SetLine(double, double, double, double)方法:设置Line对象起点的x,y坐标(第一个和第二参数)和终点的x,y坐标(第三个和第四个坐标),并返回本对象
Line::SetLine(const Point &, const Point &)方法:设置Line对象的起点(第一个参数)和终点(第二个坐标),并返回本对象
Line::SetLine(const Line&)方法:设置Line对象,复制参数的坐标,并返回本对象
Line::readLine()方法:从标准输入上读入坐标,格式见Sample

Input

输入的第一行为N,表示后面有N行测试样例。

每行为两组坐标“x,y”,分别表示线段起点和终点的x坐标和y坐标,两组坐标间用一个空格分开,x和y的值都在double数据范围内。

Output

输出为多行,每行为一条线段,起点坐标在前终点坐标在后,每个点的X坐标在前,Y坐标在后,Y坐标前面多输出一个空格,用括号包裹起来。输出格式见sample。
C语言的输入输出被禁用。

Sample Input

40,0 1,11,1 2,32,3 4,50,1 1,0

Sample Output

Point : (1, -2) is created.Point : (2, -1) is created.Point : (0, 0) is created.Point : (0, 0)Point : (0, 0) is created.Point : (0, 0) is created.Line : (0, 0) to (0, 0) is created.Point : (0, 0) is created.Point
: (0, 0) is created.Line : (0, 0) to (0, 0) is created.Point : (0, 0) is created.Point : (0, 0) is created.Line : (0, 0) to (0, 0) is created.Point : (0, 0) is created.Point : (0, 0) is created.Line : (0, 0) to (0, 0) is created.Line : (0, 0) to (1, 1)Line
: (1, 1) to (2, 3)Line : (2, 3) to (4, 5)Line : (0, 1) to (1, 0)Point : (1, -2) is copied.Point : (2, -1) is copied.Line : (1, -2) to (2, -1) is created.Point : (1, -2) is copied.Point : (0, 0) is copied.Line : (1, -2) to (0, 0) is created.Point : (2, -1)
is copied.Point : (0, 0) is copied.Line : (2, -1) to (0, 0) is created.Point : (1, -2) is copied.Point : (2, -1) is copied.Line : (1, -2) to (2, -1) is copied.Line : (1, -2) to (2, -1)Line : (1, -2) to (2, -1)Line : (2, -1) to (0, 0)Line : (0, 0) to (2, -1)Line
: (0, 0) to (2, -1) is erased.Point : (2, -1) is erased.Point : (0, 0) is erased.Line : (2, -1) to (0, 0) is erased.Point : (0, 0) is erased.Point : (2, -1) is erased.Line : (1, -2) to (2, -1) is erased.Point : (2, -1) is erased.Point : (1, -2) is erased.Line
: (1, -2) to (2, -1) is erased.Point : (2, -1) is erased.Point : (1, -2) is erased.Line : (0, 1) to (1, 0) is erased.Point : (1, 0) is erased.Point : (0, 1) is erased.Line : (2, 3) to (4, 5) is erased.Point : (4, 5) is erased.Point : (2, 3) is erased.Line
: (1, 1) to (2, 3) is erased.Point : (2, 3) is erased.Point : (1, 1) is erased.Line : (0, 0) to (1, 1) is erased.Point : (1, 1) is erased.Point : (0, 0) is erased.Point : (0, 0) is erased.Point : (2, -1) is erased.Point : (1, -2) is erased.

HINT

Append Code

append.cc

#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<string>
#include<iomanip>
using namespace std;
class Point
{
public:
double x,y;
Point(double a,double b):x(a),y(b)
{
cout<<"Point : ("<<a<<", "<<b<<") is created."<<endl;
}
void cinn(double a,double b)
{
x=a;
y=b;
}
Point():x(0),y(0)
{
cout<<"Point : (0, 0) is created."<<endl;
}
Point(const Point & p1 )
{
x=p1.x;
y=p1.y;
cout<<"Point : ("<<x<<", "<<y<<") is copied."<<endl;
}
void show()
{
cout<<"Point : ("<<x<<", "<<y<<")"<<endl;
}
~Point()
{
cout<<"Point : ("<<x<<", "<<y<<") is erased."<<endl;
}
};
class Line
{
private:
Point c,d;
//double x1,y1,x2,y2;
public:
Line(const Line & ll):c(ll.c),d(ll.d)
{
cout<<"Line : ("<<c.x<<", "<<c.y<<") to ("<<d.x<<", "<<d.y<<") is copied."<<endl;
}
Line & readLine()
{
double i,j,q,k;
char c1;
cin>>i>>c1>>j>>q>>c1>>k;
c.cinn(i,j);
d.cinn(q,k);
return *this;
}
Line & setLine(const Line & p)
{
c=p.c;
d=p.d;
return *this;
}
Line & setLine(const Point & p,const Point & q)
{
c=p;
d=q;
return *this;
}
Line():c(0,0),d(0,0)
{
cout<<"Line : (0, 0) to (0, 0) is created."<<endl;
}
Line(double a,double b,double c,double d):c(a,b),d(c,d)
{
cout<<"Line : ("<<a<<", "<<b<<") to ("<<c<<", "<<d<<") is created."<<endl;
}
Line(const Point &a,const Point & b):c(a),d(b)
{
cout<<"Line : ("<<a.x<<", "<<a.y<<") to ("<<b.x<<", "<<b.y<<") is created."<<endl;
}
~Line()
{
cout<<"Line : ("<<c.x<<", "<<c.y<<") to ("<<d.x<<", "<<d.y<<") is erased."<<endl;
}
void show()
{
cout<<"Line : ("<<c.x<<", "<<c.y<<") to ("<<d.x<<", "<<d.y<<")"<<endl;
}
};

int main()
{
int num, i;
Point p(1, -2), q(2, -1), t;
t.show();
std::cin>>num;
Line line[num];
for(i = 0; i < num; i++)
{
line[i].readLine();
line[i].show();
}
Line l1(p, q), l2(p,t), l3(q,t), l4(l1);
l1.show();
l2.setLine(l1).show();
l3.show();
l4.setLine(t,q).show();
}
/**************************************************************
Problem: 1331
User: 201701060928
Language: C++
Result: Accepted
Time:32 ms
Memory:1272 kb
****************************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: