您的位置:首页 > 产品设计 > UI/UE

poj2524——Ubiquitous Religions【并查集基础】

2018-03-23 18:33 399 查看
Ubiquitous Religions
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 38776 Accepted: 18486
DescriptionThere are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.InputThe input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.OutputFor each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.Sample Input10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample OutputCase 1: 1
Case 2: 7
HintHuge input, scanf is recommended.最近在学并查集,做一道并查集基础题巩固巩固基础知识题目大意:给你一个数N,m,输入m组数据,每组数据有两个数,把两组数据归为一类,问最后1~n中有多少组数据属于同一类(单独一组数据自成一类)。#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
typedef long long ll;
const ll MAX_N=100000;//数组不要阔的太大,不然会内存超限,之前就因为数组阔的太大wa了
ll par[MAX_N],rank[MAX_N],a[MAX_N],b[MAX_N],c[MAX_N];
void init(ll n){
for(ll i=0;i<n;i++){
par[i]=i;
rank[i]=0;
}
}
ll find(ll x){
if(par[x]==x){
return x;
}else{
return par[x]=find(par[x]);
}
}
void unite(ll x,ll y){
x=find(x);
y=find(y);
if(x==y) return;
if(rank[x]<rank[y]){
par[x]=y;
}else{
par[x]=y;
if(rank[x]==rank[y]) rank[x]++;
}
}
bool same(ll x,ll y){
return find(x)==find(y);
}
ll count_sets(ll n){
ll cnt=0;
for(ll i=1;i<=n;i++){
if(find(i)==i) cnt++;
}
return cnt;
}//统计并查集中集合的个数
int main(){
ll n,m,ans,kase=1;
while(scanf("%lld %lld",&n,&m)&&n,m){
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
ll i,j;
init(n);//初始化并查集
//for(i=1;i<=n;i++) c[i]=i;
for(i=0;i<m;i++){
scanf("%lld %lld",&a[i],&b[i]);
/*c[a[i]]=0;
c[b[i]]=0;*/
unite(a[i],b[i]);//合并为统一集合
}
ans=count_sets(n)+1;
printf("Case %lld: %lld\n",kase++,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  并查集