您的位置:首页 > 其它

FZU 2150 Fire Game

2018-03-22 13:04 239 查看
来自<http://acm.fzu.edu.cn/problem.php?pid=2150>

Problem 2150 Fire Game

Accept: 3098    Submit: 10707
Time Limit: 1000 mSec    Memory Limit : 32768 KB



 Problem Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)
You can assume that the grass in the board would never burn out and the empty grid would never get fire.
Note that the two grids they choose can be the same.



 Input

The first line of the date is an integer T, which is the number of the text cases.
Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.
1 <= T <=100, 1 <= n <=10, 1 <= m <=10



 Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.



 Sample Input

43 3.#.###.#.3 3.#.#.#.#.3 3...#.#...3 3###..##.#



 Sample Output

Case 1: 1Case 2: -1Case 3: 0Case 4: 2

题意:n*m的方格内,#代表草,放两把火,单位时间内火焰会延续到周围四格,烧不完输出-1
题解:格子范围小,可以直接暴力枚举两个放火的地方
          bfs计算已经少了的草的数量,与总数对比判断能否烧完

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string.h>
#include <queue>
#include <vector>
using namespace std;
char map[15][15];
int vis[15][15];
int T,n,m,ans,num;
struct Node{
int i,j,step;
Node(int i=0,int j=0,int step=0):i(i),j(j),step(step){}
};
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
bool check(int i,int j){
if(i<0||i>=n||j<0||j>=m||vis[i][j]||map[i][j]=='.') return true;
return false;
}
int bfs(int i,int j,int x,int y){
queue<Node>q;
q.push(Node(i,j,0));q.push(Node(x,y,0));
vis[i][j]=1;vis[x][y]=1;
int cnt;
if(i==x&&j==y) cnt=1;
else cnt=2;
while(!q.empty()){
Node t=q.front();
q.pop();
for(int k=0;k<4;k++){
int di=t.i+dir[k][0];
int dj=t.j+dir[k][1];
if(check(di,dj)) continue;
q.push(Node(di,dj,t.step+1));
vis[di][dj]=1;
cnt++;
}
if(cnt>=num&&q.empty()) return t.step;
}
return -1;
}
int main(){
scanf("%d",&T);
for(int t=1;t<=T;t++){
ans=(int)1e9;num=0;
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++){
scanf("%s",map[i]);
for(int j=0;j<m;j++) if(map[i][j]=='#') num++;
}
if(num<=2){printf("Case %d: %d\n",t,0);continue;}
for(int i=0;i<n;i++
8ec3
){
for(int j=0;j<m;j++){
if(map[i][j]!='#') continue;
for(int x=0;x<n;x++){
for(int y=0;y<m;y++){
if(map[x][y]!='#') continue;
memset(vis,0,sizeof(vis));
int tmp=bfs(i,j,x,y);
if(tmp>0)
ans=min(ans,tmp);
}
}
}
}
if(ans==(int)1e9) ans=-1;
printf("Case %d: %d\n",t,ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: