您的位置:首页 > 编程语言 > Java开发

ACM 1002题 A + B Problem II

2018-03-21 22:06 330 查看

A + B Problem II

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 406159    Accepted Submission(s): 78700

[/align][align=left]Problem Description[/align] I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
[align=left]Input[/align] The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
[align=left]Output[/align] For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 [align=left]Sample Input[/align]
21 2112233445566778899 998877665544332211 [align=left]Sample Output[/align]
Case 1:1 + 2 = 3Case 2:112233445566778899 + 998877665544332211 = 1111111111111111110 [align=left]Author[/align] Ignatius.L 
链接地址:http://acm.hdu.edu.cn/showproblem.php?pid=1002
 import java.math.*;
import java.util.*;

public class Main extends Object {

private static final Scanner cache = new Scanner(System.in);

public static void main(String[] args) {

String a = new String();
String b = new String();
int j = 0;

for (int i = cache.nextInt(); i > 0; i--) {
j++;
a = cache.next();
b = cache.next();

BigInteger bA = new BigInteger(a);
BigInteger bB = new BigInteger(b);

BigInteger sum = bA.add(bB);

System.out.println("Case " + j + ":");
System.out.println(bA.toString() + " + " + bB.toString() + " = " + sum.toString());
if (!(i == 1)) {
System.out.println();
}
}

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM Java 真题