您的位置:首页 > 其它

poj 2484 A Funny Game

2018-03-21 19:52 357 查看
A Funny Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6473 Accepted: 4027
DescriptionAlice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 106) coins in a circle, as Figure 1 shows. A move consists in removing one or two adjacent coins, leaving all other coins untouched. At least one coin must be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can't move, you lose.)



Figure 1
Note: For n > 3, we use c1, c2, ..., cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent! (Because there is an empty place between c1 and c3.)

Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game. InputThere are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.
OutputFor each test case, if Alice win the game,output "Alice", otherwise output "Bob".
Sample Input1
2
3
0
Sample OutputAlice
Alice
BobSourcePOJ Contest,Author:Mathematica@ZSU
#include <iostream>

using namespace std;

int main()
{
int n;
while(~scanf("%d", &n) && n){
if(n == 1 || n == 2){
printf("Alice\n");
}
else
printf("Bob\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: