您的位置:首页 > 其它

【PAT】1005. Spell It Right (20)

2018-03-21 08:36 495 查看

题目描述:

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

翻译:给一个非负的整数N,你的任务是将N的所有数字相加求和,然后用英文输出和的每一位数字。

INPUT FORMAT

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

翻译:每个输入文件包含一组测试数据。每组测试数据包含一个N (<=10^100)

OUTPUT FORMAT

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

翻译:对于每组测试数据,在一行内输出和的每一位数字的英文单词。每两个连续的单词之间必须用空格隔开,但是行的末尾不能有空格。

Sample Input:

12345

Sample Output:

one five

解题思路

简单模拟题,根据题目描述写就可以了,数字输出英文可以用字符串数组,注意当输入为0时的情况。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
char a[110];
char digit[10][10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
int main(){
scanf("%s",a);
int length=strlen(a);
int sum=0;
for(int i=0;i<length;i++){
a[i]=a[i]-'0';
sum+=a[i];
}
if(sum==0)printf("%s",digit[0]);
int ans[5],ccount=0;
while(sum){
ans[ccount++]=sum%10;
sum/=10;
}
for(int i=ccount-1;i>=0;i--){
if(i==ccount-1)printf("%s",digit[ans[i]]);
else printf(" %s",digit[ans[i]]);
}
printf("\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT 算法 甲级