您的位置:首页 > 编程语言 > C语言/C++

【HDU】1196 Lowest Bit

2018-03-19 21:57 316 查看
[align=left]Problem Description[/align]Given an positive integer A (1 <= A <= 100), output the lowest bit of A.For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.[align=left]Input[/align]Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.[align=left]Output[/align]For each A in the input, output a line containing only its lowest bit.[align=left]Sample Input[/align]
26
88
0[align=left]Sample Output[/align]
2
8
    这道题我用的是一个比较简单的方法,就是通过模2取余判断“lowest bit”。

   代码:#include <stdio.h>

int main() {
int n,t;
while (scanf("%d",&n)!=EOF&&n!=0) {
t=1;
while (n%2!=1) {
t=t*2;
n=n/2;
}
printf("%d\n",t);
}
return 0;
}但是刚看完题目时,想到的方法就是先找到这个数的二进制表示,然后再找到倒数第一个1的位数,就可以得到结果。
下面写了一个把整数转为二进制表示的程序,大家可以参考一下,也能把这道题完成~
代码(数的二进制表示)#include <stdio.h>

int main() {
int b[30];
int n,i=0,j;
scanf("%d",&n);
while (n!=0)
{
b[i]=n%2;
n=n/2;
i++;
}
// printf("%d\n",i);
// printf("%d\n",b[1]);
for (j=i-1; j>=0; j--)
printf("%d",b[j]);
printf("\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C语言