您的位置:首页 > 其它

ZOJ 1151 - Word Reversal(字符串反转)

2018-03-19 21:27 363 查看
For each list of words, output a line with each word reversed without changing the order of the words.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

对于每个单词列表,输出一个每个单词颠倒的行而不改变单词的顺序。

这个问题包含多个测试用例!

多输入的第一行是整数N,然后是空行,后面是N个输入块。 每个输入块都采用问题描述中指定的格式。 输入块之间有空行。

输出格式由N个输出块组成。 输出块之间有空行。

Input

You will be given a number of test cases. The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words separated by one space, and each word contains only uppercase and lowercase letters.

你会得到一些测试用例。 第一行包含一个正整数,表示要遵循的病例数量。 每个案例在包含由一个空格分隔的单词列表的行上给出,每个单词只包含大写和小写字母。

Output

For each test case, print the output on one line.

对于每个测试用例,在一行上打印输出。

Sample Input

1

3

I am happy today

To be or not to be

I want to win the practice contest

Sample Output

I ma yppah yadot

oT eb ro ton ot eb

I tnaw ot niw eht ecitcarp tsetnoc

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

const int MAX = 1e6+10;
const int INF = 0x3fffffff;
char s[MAX];
char b[MAX];
int main(){
int t;
cin>>t;
int ca=0;
while(t--){
int n;
scanf("%d",&n);
getchar();
if(ca++)    cout<<endl;//坑在这里,如果有多组输入的话,需要换行
for(int i=0;i<n;i++){
memset(s,0,sizeof(s));
memset(b,0,sizeof(b));
gets(s);
int len = strlen(s);
int temp=0;
for(int i=0;i<len;i++){
if(s[i]==' '){
b[i]=' ';
for(int j=0;j<temp;j++){
b[i-temp+j]=s[i-j-1];

}
temp=0;
}
else{
temp++;
}
}
printf("%s",b);
for(int i=len-1;i>=len-temp;i--){
printf("%c",s[i]);
}
cout<<endl;
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: