您的位置:首页 > 其它

Ignatius and the Princess IV

2018-03-19 12:48 441 查看
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says. 

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says. 

"But what is the characteristic of the special integer?" Ignatius asks. 

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says. 

Can you find the special integer for Ignatius? 
InputThe input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file. 
OutputFor each test case, you have to output only one line which contains the special number you have found. 
Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1
Sample Output
3
5
1

最近在学动态规划,做到这道题,最开始想用动态规划的方法解这道题,想了半天没想出来,后来果断放弃动态规划,直接把没一个数用一个数组标记一下就行了,最后找出大于(n+1)/2的就行了#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
#define MAXN 1000000
int a[MAXN+10];
int main(){
int n;
int t,count;
while(scanf("%d",&n)!=EOF){
memset(a,0,sizeof(a));
for(int i=1;i<=n;i++){
scanf("%d",&t);
a[t]++;
if(a[t]>=(n+1)/2){
count=t;
}
}
printf("%d\n",count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  水题 动态规划