您的位置:首页 > 编程语言 > C语言/C++

C/C++经典程序训练3---模拟计算器(类)

2018-03-19 11:21 561 查看

Problem Description

简单计算器模拟:输入两个整数和一个运算符,输出运算结果。

Input

第一行输入两个整数,用空格分开;
第二行输入一个运算符(+、-、*、/)。
所有运算均为整数运算,保证除数不包含0。

Output

输出对两个数运算后的结果。

Sample Input

30 50
*

Sample Output

1500


import java.util.Scanner;
class compute {
int a, b;
char c;
public compute(int a, int b, char c) {
this.a = a;
this.b = b;
this.c = c;
}
public int jisuan(){
if(c=='+'){
return a+b;
}
else if(c=='-'){
return a-b;
}
else if(c=='*'){
return a*b;
}
else if(c=='/'){
return a/b;
}
else{
return 0;
}
}

}
public class Main {

public static void main(String[] args) {
Scanner reader = new Scanner(System.in);
int a = reader.nextInt();
int b = reader.nextInt();

String s = reader.nextLine();
s = reader.nextLine();
char c = s.charAt(0);
compute rect = new compute(a,b,c);
int sum = rect.jisuan();
System.out.println(sum);
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: