您的位置:首页 > 其它

POJ-2406 Power Strings (KMP)

2018-03-18 14:52 453 查看

Problem Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Ouput

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd

aaaa

ababab

.

Sample Output

1

4

3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

思路

这几天看KMP看的云里雾里……好像有点理解了它的思想了。关于这道题目,首先根据KMP的思想求出给定字符串对应的next数组,可知len-next[len]为该字符串最短循环子串的长度,若len%(len-next[len]) == 0则存在n符合题意,否则不存在。关于这个思想的理解我是参考了博客POJ 2406 Power Strings (KMP) 总觉得还要再好好理解理解KMP啊(雾

代码

#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<string.h>

using namespace std;

char str[1000010];
int len, ans, next[1000010];

void getNext() {
int i = 0, j = -1;
next[0] = -1;
while(i < len) {
if (j == -1 || str[i] == str[j]) {
i++;
j++;
next[i] = str[i] != str[j] ? j : next[j];

}
else
j = next[j];
}
}

int main() {
while(scanf("%s", str)) {
if(str[0] == '.')
break;
len = strlen(str);
getNext();
if(len % (len - next[len]) == 0)
ans = len / (len - next[len]);
else
ans = 1;
cout << ans << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: