您的位置:首页 > 其它

HDU 1213 How Many Tables (并查集)

2018-03-17 16:02 549 查看
题目链接:
       HDU 1213 How Many Tables
题目:

How Many Tables

                                              Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

[align=left]Problem Description[/align]Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 
[align=left]Input[/align]The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 
[align=left]Output[/align]For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 
[align=left]Sample Input[/align]
2
5 3
1 2
2 3
4 5

5 1
2 5 
[align=left]Sample Output[/align]
2
4
题目分析:
         本题求需要多少桌子,这是一个简单的并查集问题,如果这些人互相认识那么他们的最上级相同且只有那个数的上级为自身,所以只需求有几个人的最上级为自己即可。
AC代码:#include <stdio.h>
int f[1005];
int Find(int x)//找最上级
{
while(x!=f[x])
x=f[x];
return x;
}
void join(int a,int b)
{
int x=Find(a),y=Find(b);
if (x!=y)
f[x]=y;
}
int main()
{
int T,n,m,a,b,ans;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
for (int i=0; i<=n; i++)
f[i]=i;
while(m--)
{
scanf("%d%d",&a,&b);
join(a,b);
}
ans=0;
for (int i=1; i<=n; i++)
if (Find(i)==i)//判断最上级是否为自身
ans++;
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU 并查集