您的位置:首页 > 其它

pat甲级1058. A+B in Hogwarts (20)

2018-03-17 10:56 537 查看

1058. A+B in Hogwarts (20)

时间限制50 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue
If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).Input Specification:Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.Output Specification:For each test case you should output the sum of A and B in one line, with the same format as the input.Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28
算法设计:
这是一道进制转换的题目,理论上来讲这样的进制转换题目都有两种方法:(1)将输入数据统一转换到最小单位,进行指定运算后,再将得到的结果转换到所要输出的格式;(2)从最小单位开始进行指定运算,向上级单位产生进位或借位,得出最终结果。下面分别给出这两种方法的代码:

第一种方法的C++代码:

#include<bits/stdc++.h>
using namespace std;
int main(){
int a[3]={0},b[3]={0};
scanf("%d.%d.%d %d.%d.%d",&a[0],&a[1],&a[2],&b[0],&b[1],&b[2]);
long long sum=((long long)a[0]*17+a[1])*29+a[2];//有可能超出int存储范围,最好用long long存储
sum+=((long long)b[0]*17+b[1])*29+b[2];
printf("%lld.%lld.%lld",sum/(29*17),sum/29%17,sum%29);
return 0;
}

第二种方法的C++代码:

#include<bits/stdc++.h>
using namespace std;
void add(int *a,int *b){
a[2]+=b[2];
if(a[2]>=29){
++a[1];
a[2]%=29;
}
a[1]+=b[1];
if(a[1]>=17){
++a[0];
a[1]%=17;
}
a[0]+=b[0];
}
int main(){
int a[3]={0},b[3]={0};
scanf("%d.%d.%d %d.%d.%d",&a[0],&a[1],&a[2],&b[0],&b[1],&b[2]);
add(a,b);
printf("%d.%d.%d",a[0],a[1],a[2]);
return 0;
}
乙级1037. 在霍格沃茨找零钱(20)是一道类似的题目,不过它要求计算的是进制的减法,这道题要求做的是进制的加法,有兴趣的同学可以去看一下。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: