您的位置:首页 > 其它

Problem K:Oil Deposits(HDU 1241)

2018-03-16 14:57 190 查看

Problem Description

    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

Input

    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

     For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5 
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0 

Sample Output

   0
   1
   2
   2————————————————————————————————————————————思路:    基础的dfs,向8个方向深搜即可

Source Program

#include<cstring>
#include<iostream>
using namespace std;

int m,n;
char mapp[105][105];
int direction[8][2]={{-1,0},{1,0},{0,-1},{0,1},{-1,-1},{-1,1},{1,-1},{1,1}};//方向向量

void dfs(int x0,int y0)
{
int x,y;
int i;

for(i=0;i<8;i++)
{
x=x0+direction[i][0];
y=y0+direction[i][1];

if(x>=0&&x<m&&y>=0&&y<n)//判断是否越界
{
if(mapp[x][y]=='@')//判断是否有友
{
mapp[x][y]='*';//开采
dfs(x,y);//继续深搜
}
}
}
}
int main()
{
int sum;
int i,j;

while(cin>>m>>n)//输入地图大小
{
if(m==0)    break;

for(i=0;i<m;i++)
for(j=0;j<n;j++)
cin>>mapp[i][j];

sum=0;//计数器归零
for(i=0;i<m;i++)
{
for(j=0;j<n;j++)
{
if(mapp[i][j]=='@')//如果有油
{
mapp[i][j]='*';//开采
dfs(i,j);//进行深搜
sum++;
}
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: