您的位置:首页 > 其它

POJ 3461 Oulipo 【KMP多次匹配,新手入门】

2018-03-15 21:10 363 查看

Oulipo

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 45696 Accepted: 18242

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3

BAPC

BAPC

AZA

AZAZAZA

VERDI

AVERDXIVYERDIAN

Sample Output

1

3

0

Source

BAPC 2006 Qualification

题意 :给你n组字符串,每组两个,问你每组中第一个字符串在第二个字符串中出现了几次

分析: 由于KMP算法学了好久,今天复习了下,发现好多地方都忘了,比如求
Next
数组时,把最后一个字符漏了,还有不扫细节,我的KMP的板子是参考的July的,具体详细思路这里,当做板子吧,还有就是POJ的一个通病,就是c++的输入出流很慢,建议吧同步异动关了 :
ios_base::sync_with_stdio(false);


参考代码

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>

using namespace std;

const int maxn = 1e4 + 10;

int Next[maxn];

void getNext(string s) {
int len = s.size();
int k = -1,j = 0;
Next[0] = k;
while (j < len) { // 注意这里,因为这里要匹配多次
if(k == -1 || s[k] == s[j]) {
j++,k++;
Next[j] = k;
} else k = Next[k];
}
}

int main() {
ios_base::sync_with_stdio(false);
int T;cin>>T;
while (T--) {
memset(Next, 0, sizeof Next);
string s1,s2;cin>>s1>>s2;
getNext(s1);
int res = 0;
int lenS = s2.size();
int j = 0,i = 0;
while (i < lenS) {
if (j == -1 || s2[i] == s1[j]) {
i++,j++;
if (j >= s1.size()) {
res++;
j = Next[j]; // 注意
}
} else {
j = Next[j];
}
}
cout<< res <<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: