您的位置:首页 > 其它

杭电 acm 2054 A==B?

2018-03-15 11:48 375 查看
A == B ?
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 118729    Accepted Submission(s): 18964

Problem Description

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

 

Input

each test case contains two numbers A and B.

 

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

 

Sample Input

1 2
2 2
3 3
4 3

 

Sample Output

NO
YES
YES
NO

 

Author

8600 && xhd

#include<iostream>
#include<string.h>
#include<string>
using namespace std;
int spt(char x[])
{
for(int i=0;x[i]!=0;i++)
{
if(x[i]=='.')
return 1;
}
return 0;
}
void zero(char x[],int y)
{
if(spt(x))
{
int l=y-1;
while(x[l]=='0')
{
x[l]=0;
l--;
}
if(x[l]=='.')
{
x[l]=0;
l--;
}
y=l;
}
}
int main()
{
char a[100000],b[100000];
while(cin>>a>>b)
{
int l1=strlen(a),l2=strlen(b);
zero(a,l1);
zero(b,l2);
if(strcmp(a,b)==0)
cout<<"YES"<<endl;
else
cout<<"NO"<<endl;
}
return 0;
} 这个刚开始看着好容易,wa了一次发现没那么简单,要判断是否有小数点以及小数点后面的0,如果是12.20000那么就将2后面的0全部去掉,再进行字符串比较即strcmp()
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: