您的位置:首页 > 其它

HDU 1712 ACboy needs your help (分组背包入门 1)

2018-03-14 22:16 429 查看
[align=left]Problem Description[/align] ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 [align=left]Input[/align] The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 [align=left]Output[/align] For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 [align=left]Sample Input[/align]
2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0 Sample Output
3
4
6

解题思路:这是一个组合背包,每一组你最多取一个,或者不取任何一个,然后在有限的容量中取最大的价值

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=110;
int n,m,num[maxn][maxn],dp[maxn];
int main(){
int i,j,k;
while(scanf("%d%d",&n,&m)!=EOF){
if(n==0&&m==0) break;
for(i=1;i<=n;i++){
for(j=1;j<=m;j++)
scanf("%d",&num[i][j]);
}
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++){
for(j=m;j>=1;j--){
for(k=1;k<=j;k++){
dp[j]=max(dp[j],dp[j-k]+num[i][k]);
}
}
}
printf("%d\n",dp[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: