您的位置:首页 > 理论基础 > 数据结构算法

传说中的数据结构

2018-03-14 20:21 232 查看
Problem Description

在大学里学习了一个学期了,大家大都对所学的专业有了基本的了解。许多同学也已经知道了到大二要开一门课叫做《数据结构》,那么今天给你们提前讲一下一个最简单的数据结构:栈。 栈的基本操作有3种:push,pop,top。


例如,给你一个数列:1 2 3 4

push:向栈中加入一个数,比如push 5,数列就变成1 2 3 4 5。

pop:从栈中删除最后面的数,比如 pop,数列就变成1 2 3。(数列变化,但是不输出。如果栈是空的,即不能 pop 操作,那就输出 error ,但是接下来的操作还是要继续的)。

top:找出栈最后面的数,比如 top ,你就要输出4。(如果栈中没有数的话,即不能 top 操作,那就输出 empty)。

然后,你们可以看出来了吧,其实栈就是一个先进后出(越先进去的元素越后面出来)的数据结构,很简单吧,下面要检验下你们的学习效果了。

Input

输入包含多组测试数据.

每组数据的第一行为一个整数 T(1 <= T <= 1000 ),接下来 T 行为对栈的操作。

Output

如果操作是top,那么输出最后面的数,如果栈中没有数的话,那就输出“empty”(不含引号)。

如果操作是pop且栈是空的,那么输出 “error”(不含引号)。

在每组测试数据的最后多加一次换行。

Sample Input

8

push 1

push 2

push 3

push 4

top

pop

top

pop

3

push 1

pop

top

Sample Output

4

3

empty

错误:

import java.util.Arrays;
import java.util.Scanner;

public class Main {

public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int b[] = new int[10010];
int t;
while(sc.hasNext()){
t = 0;
int n = sc.nextInt();
sc.nextLine();
while(n-- != 0){
String s = sc.next();
if(s == "push"){
int a = sc.nextInt();
sc.nextLine();
b[t++] = a;
}
else if(s == "pop"){
if(t < 0){
System.out.println("error");
}
else{
t--;
}
}
else if(s == "top"){
if(t < 0){
System.out.println("empty");
}
else{
System.out.println(b[t-1]);
}
}
}
System.out.println();
}

sc.close();
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: