您的位置:首页 > 其它

4.9 矩阵(数组应用的典型范例3)

2018-03-13 23:03 417 查看
zoj 1949

Error Correction
A boolean matrix has the parity property when each row and each column has an even sum, i.e. contains an even number of bits which are set. Here's a 4 x 4 matrix which has the parity property:
1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
The sums of the rows are 2, 0, 4 and 2. The sums of the columns are 2, 2, 2 and 2.

Your job is to write a program that reads in a matrix and checks if it has the parity property. If not, your program should check if the parity property can be established by changing only one bit. If this is not possible either, the matrix should be classified as corrupt.

Input

The input will contain one or more test cases. The first line of each test case contains one integer n (n < 100), representing the size of the matrix. On the next n lines, there will be n integers per line. No other integers than 0 and 1 will occur in the matrix. Input will be terminated by a value of 0 for n.

Output

For each matrix in the input file, print one line. If the matrix already has the parity property, print "OK". If the parity property can be established by changing one bit, print "Change bit (i,j)" where i is the row and j the column of the bit to be changed. Otherwise, print "Corrupt".

Sample Input

4
1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 0 1 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 1 1 0
1 1 1 1
0 1 0 1
0

Sample Output

OK
Change bit (2,3)
Corrupt

#include <stdio.h>
int main(){

    int num=0;
    scanf("%d",&num);
    while(num!=0){
 int tag[100][100]={0};
    int i=0,j=0;
    for(i=0;i<num;i++){
        for(j=0;j<num;j++){
            scanf("%d",&tag[i][j]);
        }
        getchar();

    }

    int row[100]={0},column[100]={0};
    int row1=0,column1=0;

    for(i=0;i<num;i++){
            int sum=0;
        for(j=0;j<num;j++){
            sum+=tag[i][j];
        }
        if(sum%2==0){
            row[i]=0;
        }else{
            row[i]=1;
        }
        row1+=row[i];

    }

    for(j=0;j<num;j++){
        int sum=0;
        for(i=0;i<num;i++){
            sum+=tag[i][j];
        }
        if(sum%2==0){
            column[j]=0;
        }else{
            column[j]=1;
        }
        column1+=column[j];

    }

    if(row1==0&&column1==0){
        printf("OK\n");
    }else if(row1==1&&column1==1){
        int m,n;
        for(i=0;i<num;i++){
            if(row[i]==1){
                m=i;
                break;
            }
        }
        for(i=0;i<num;i++){
            if(column[i]==1){
                n=i;
                break;
            }
        }
        printf("Change bit (%d,%d)\n",m+1,n+1);
    }else {
        printf("Corrupt\n");
    }

    scanf("%d",&num);
    }

    return 0;

}

两个方面:==等于与=号赋值..竟然还用错..

输出格式bit 与 ()之间有空格 没有空格一直错..
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  算法
相关文章推荐