您的位置:首页 > 其它

POJ1975解题报告-Floyd解决传递闭包

2018-03-13 17:34 274 查看
B - Median Weight BeadTime Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64uSubmit Status use MathJax to parse formulasDescriptionThere are N beads which of the same shape and size, but with different weights. N is an odd number and the beads are labeled as 1, 2, ..., N. Your task is to find the bead whose weight is median (the ((N+1)/2)th among all beads). The following comparison has been performed on some pairs of beads: 
A scale is given to compare the weights of beads. We can determine which one is heavier than the other between two beads. As the result, we now know that some beads are heavier than others. We are going to remove some beads which cannot have the medium weight. 

For example, the following results show which bead is heavier after M comparisons where M=4 and N=5. 
1.	Bead 2 is heavier than Bead 1.

2.	Bead 4 is heavier than Bead 3.

3.	Bead 5 is heavier than Bead 1.

4.	Bead 4 is heavier than Bead 2.

From the above results, though we cannot determine exactly which is the median bead, we know that Bead 1 and Bead 4 can never have the median weight: Beads 2, 4, 5 are heavier than Bead 1, and Beads 1, 2, 3 are lighter than Bead 4. Therefore, we can remove these two beads. 

Write a program to count the number of beads which cannot have the median weight. 
InputThe first line of the input file contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows: 
The first line of input data contains an integer N (1 <= N <= 99) denoting the number of beads, and M denoting the number of pairs of beads compared. In each of the next M lines, two numbers are given where the first bead is heavier than the second bead. 
OutputThere should be one line per test case. Print the number of beads which can never have the medium weight.Sample Input
1
5 4
2 1
4 3
5 1
4 2
Sample Output2求解:经过m场比重,n个水滴中有几个水滴可以排除一定不是中间重量的水滴?
解析:当且仅当有(int)(n+1)/2以上个水滴比该水滴重或者有(int)(n+1)/2以上个水滴比该水滴轻的时候,这个水滴可以被排除一定不是中间重量的水滴
代码如下:#include <iostream>
#include<stdio.h>
using namespace std;
const int N=100+5;
const int M=4500+50;
const int MAX=0x3f3f3f3f;
int n,m;
int mapa

;
int main()
{
int num;
scanf("%d",&num);
while(num--)
{
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{
if(i==j)
mapa[i][j]=0;
else
mapa[i][j]=MAX; //mapa初始化
}
for(int i=1;i<=m;i++)
{
int a,b;
scanf("%d%d",&a,&b);
mapa[a][b]=1;
}
int sum=0;
for(int k=1;k<=n;k++)
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
if(mapa[i][k]==1&&mapa[k][j]==1) //如果i比k重,k比j重,那么i一定比j重
{
mapa[i][j]=1;
}

for(int i=1;i<=n;i++)
{
int s=0;
for(int j=1;j<=n;j++)
{
if(mapa[i][j]==1) //比它重
s++;
}
if(s>=(n+1)/2)
{
sum++;
continue;
}
s=0; //别忘了清零
for(int j=1;j<=n;j++)
{
if(mapa[j][i]==1) //比他轻
s++;
}
if(s>=(n+1)/2)
sum++;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Floyd 传递闭包