您的位置:首页 > 其它

PAT 1011. World Cup Betting (20)

2018-03-13 13:25 441 查看
With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.For example, 3 games' odds are given as the following: W T L
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).InputEach input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.OutputFor each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.Sample Input
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
Sample OutputT T W 37.98思路:本题难度不高,题目意思是进行三轮比赛,分为W,T,L三种赌注,每种赌注对应有相应的值。要求三轮比赛下来的最大值。按照样例计算公式为 (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans。注意:样例给出的是四舍五入后的结果,但实际提交代码并未有这个要求。如果要进行四舍五入操作的话,可以先保留小数点后三位,然后加上0.005。#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f

int main() {
double a[100][100];
int i,j;
for(i=0; i<3; i++)
for(j=0; j<3; j++)
scanf("%lf",&a[i][j]);
double sum=1,max=0;
char typ[3],p[3]={'W','T','L'};
int tmp;
for(i=0; i<3; i++) {
max=0;
for(j=0; j<3; j++) {
if(max<a[i][j])
{max=a[i][j];tmp=j;}
}
sum*=max;typ[i]=p[tmp];
}
for(i=0;i<3;i++)
printf("%c ",typ[i]);
printf("%.2f\n",(sum*0.65-1)*2);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: