您的位置:首页 > 其它

1058. A+B in Hogwarts (20)

2018-03-12 18:43 344 查看

1058. A+B in Hogwarts (20)

时间限制50 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue
If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).Input Specification:Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.Output Specification:For each test case you should output the sum of A and B in one line, with the same format as the input.Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28

点击打开链接
#include<stdio.h>
int main()
{
int a,b,c,a1,b1,c1;
scanf("%d.%d.%d",&a,&b,&c);
scanf("%d.%d.%d",&a1,&b1,&c1);
a=a+a1;
b=b+b1;
c=c+c1;
if(c>=29)
{
c-=29;
b+=1;
}
if(b>=17)
{
b-=17;
a+=1;
}
printf("%d.%d.%d\n",a,b,c);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: