您的位置:首页 > 其它

POJ3255 Roadblocks(次短路问题)

2018-03-12 18:34 274 查看
Roadblocks
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17736 Accepted: 6222
DescriptionBessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.
The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.
The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).
InputLine 1: Two space-separated integers: N and R 
Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)OutputLine 1: The length of the second shortest path between node 1 and node NSample Input4 4
1 2 100
2 4 200
2 3 250
3 4 100Sample Output450题意:求一个1到n的次短路,双向边,可以回走.
讲的很好的一个博客,点击打开,代码详解

代码:#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstring>
#include<string>
#include<vector>
#include<cmath>
#include<map>
#define mem(a,b) memset(a,b,sizeof(a))
#define mod 1000000007
using namespace std;
typedef long long ll;
const int maxn = 2e5+5;
const double esp = 1e-7;
const int ff = 0x3f3f3f3f;
map<int,int>::iterator it;

struct node
{
int to,w,next;
} r[maxn];//此题记得maxn至少要为2e5,别问我是怎么知道的

struct node2
{
int pos,cost;
node2(int pos = 0,int cost = 0):pos(pos),cost(cost){}
} ;

int n,m;
int dis[maxn],disc[maxn];// 存储最短路和次短路
int len,head[maxn];

void add(int a,int b,int c)
{
r[len].to= b;
r[len].w = c;
r[len].next = head[a];
head[a] = len++;
}

bool operator< (node2 a,node2 b)
{
return a.cost> b.cost;
}

void dijkstra()//堆优化的dijkstra
{
priority_queue<node2> q;

q.push(node2(1,0));
dis[1] = 0;

while(!q.empty())
{
node2 t = q.top();
q.pop();

if(t.cost> disc[t.pos])//比到此点的次短路长度还长,当然没用啦
continue;

for(int i = head[t.pos];i!= -1;i = r[i].next)
{
int id = r[i].to;
int d = t.cost+r[i].w;

if(d< dis[id])
{
swap(d,dis[id]);//记得用swap,还要把dis[id]的值传给disc[id]
q.push(node2(id,dis[id]));
}

if(d> dis[id]&&d< disc[id])
{
disc[id] = d;
q.push(node2(id,disc[id]));
}
}
}

cout<<disc
<<endl;
}

int main()
{
mem(dis,ff);
mem(disc,ff);
mem(head,-1);

cin>>n>>m;

for(int i = 1;i<= m;i++)
{
int a,b,c;
scanf("%d %d %d",&a,&b,&c);
add(a,b,c);
add(b,a,c);
}

dijkstra();

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 次短路 Dijkstra