您的位置:首页 > 运维架构

Open Credit System UVA - 11078

2018-03-12 11:11 369 查看

题目

In an open credit system, the students can choose any course they like, but there is a problem. Some

of the students are more senior than other students. The professor of such a course has found quite a

number of such students who came from senior classes (as if they came to attend the pre requisite course

after passing an advanced course). But he wants to do justice to the new students. So, he is going to

take a placement test (basically an IQ test) to assess the level of difference among the students. He

wants to know the maximum amount of score that a senior student gets more than any junior student.

For example, if a senior student gets 80 and a junior student gets 70, then this amount is 10. Be careful

that we don’t want the absolute value. Help the professor to figure out a solution.

Input

Input consists of a number of test cases T (less than 20). Each case starts with an integer n which is

the number of students in the course. This value can be as large as 100,000 and as low as 2. Next n

lines contain n integers where the i’th integer is the score of the i’th student. All these integers have

absolute values less than 150000. If i < j, then i’th student is senior to the j’th student.

Output

For each test case, output the desired number in a new line. Follow the format shown in sample

input-output section.

Sample Input

3

2

100

20

4

4

3

2

1

4

1

2

3

4

Sample Output

80

3

-1

题意

给定一个整数序列a[0]、a[1]、a[2]…a[n-1].求a[i]-a[j]的最大值,其中i小于j.

分析

如果通过两层循环遍历求最大值,时间复杂度为O(n*n).而n的最大值为1e5,肯定会超时。

对于固定的j,我们要选i小于j且a[i]的值最大的i。所以,我们可以枚举j并维护a[i]。

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
#define INF 0x3f3f3f3f

using namespace std;

int n,largest,ans;

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
int x;
scanf("%d",&x);
ans=-INF;
largest=x;
for(int i=1;i<n;i++)
{

scanf("%d",&x);
ans=max(ans,largest-x);
largest=max(largest,x);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: