您的位置:首页 > 其它

POJ - 3255 Roadblocks —— 次短路

2018-03-11 19:55 399 查看
Roadblocks
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17711 Accepted: 6210
DescriptionBessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.
The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.
The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).
InputLine 1: Two space-separated integers: N and R 
Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)OutputLine 1: The length of the second shortest path between node 1 and node NSample Input4 4
1 2 100
2 4 200
2 3 250
3 4 100Sample Output450HintTwo routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)
题意:
有n个点和m条路,问从点1到点n的次短路是多少
思路:
次短路的模板题
假设从u到v有一条路,那么到v点的次短路,要么是到u点的最短路+u到v的长度,要么是到u点的次短路+u到v的长度
在dijkstra的更新中加入次短路的部分,随最短路不断更新,详细见代码#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#define max_ 5010
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
struct node
{
int to,w;
bool operator < (const node &a)const
{
return a.w<w;
}
}zz;
priority_queue<struct node>q;
int n,m;
vector<struct node>v[max_];
int dis[max_],dis2[max_];//dis是最短路,dis2是次短路
void dij()
{
while(!q.empty())
{
zz=q.top();
q.pop();
int u=zz.to;
int d=zz.w;
if(dis2[u]<zz.w)//若zz.w比dis[u]大,则不会是最短路,若比dis2[u]大,则不会是次短路,那就没有必要用这个点进行松弛了
continue;
for(int i=0;i<v[u].size();i++)
{
zz=v[u][i];
int dd=zz.w+d;//不能写作dd=zz.w+dis[u],因为我们这条边也有可能是来松弛次短路的
if(dd<dis[zz.to])//松弛最短路
{
zz.w=dd;
swap(dis[zz.to],dd);
q.push(zz);
}
if(dd>dis[zz.to]&&dd<dis2[zz.to])//松弛次短路
{
dis2[zz.to]=dd;
zz.w=dd;
q.push(zz);
}
}
}
}
int main(int argc, char const *argv[]) {
scanf("%d%d",&n,&m);
while(m--)
{
int x,y,w;
scanf("%d%d%d",&x,&y,&w);
zz.to=x;
zz.w=w;
v[y].push_back(zz);
zz.to=y;
v[x].push_back(zz);
}
memset(dis,inf,sizeof dis);
memset(dis2,inf,sizeof dis2);
zz.to=1;
zz.w=0;
q.push(zz);
dis[1]=0;
dij();
printf("%d\n",dis2
);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: