您的位置:首页 > 编程语言 > PHP开发

HDU-1092 A+B for Input-Output Practice (IV)

2018-03-11 17:14 447 查看
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


[align=left]Problem Description[/align]Your task is to Calculate the sum of some integers.
 
[align=left]Input[/align]Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
 
[align=left]Output[/align]For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 
[align=left]Sample Input[/align]
4 1 2 3 45 1 2 3 4 50  [align=left]Sample Output[/align]
1015
[align=left]Author[/align]lcy
C++代码
#include <iostream>
using namespace std;
int main()
{
int n,m;
int i;
int sum;
while(cin>>n)
{
if(n!=0)
{
sum=0;
while(n--)
{
cin>>m;
sum+=m;
}
cout<<sum<<endl;
}
else break
}
return 0;
}

一、相对于前三道题,这道题的输入是由一个数字n和n个正整数组成
二、当n为0时结束
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: