您的位置:首页 > 其它

ccf认证题-炉石传说

2018-03-11 17:04 162 查看
问题描述

《炉石传说:魔兽英雄传》(Hearthstone: Heroes of Warcraft,简称炉石传说)是暴雪娱乐开发的一款集换式卡牌游戏(如下图所示)。游戏在一个战斗棋盘上进行,由两名玩家轮流进行操作,本题所使用的炉石传说游戏的简化规则如下:

  * 玩家会控制一些角色,每个角色有自己的生命值和攻击力。当生命值小于等于 0 时,该角色死亡。角色分为英雄和随从。

  * 玩家各控制一个英雄,游戏开始时,英雄的生命值为 30,攻击力为 0。当英雄死亡时,游戏结束,英雄未死亡的一方获胜。

  * 玩家可在游戏过程中召唤随从。棋盘上每方都有 7 个可用于放置随从的空位,从左到右一字排开,被称为战场。当随从死亡时,它将被从战场上移除。

  * 游戏开始后,两位玩家轮流进行操作,每个玩家的连续一组操作称为一个回合。

  * 每个回合中,当前玩家可进行零个或者多个以下操作:

  1) 召唤随从:玩家召唤一个随从进入战场,随从具有指定的生命值和攻击力。

  2) 随从攻击:玩家控制自己的某个随从攻击对手的英雄或者某个随从。

  3) 结束回合:玩家声明自己的当前回合结束,游戏将进入对手的回合。该操作一定是一个回合的最后一个操作。

  * 当随从攻击时,攻击方和被攻击方会同时对彼此造成等同于自己攻击力的伤害。受到伤害的角色的生命值将会减少,数值等同于受到的伤害。例如,随从 X 的生命值为 HX、攻击力为 AX,随从 Y 的生命值为 HY、攻击力为 AY,如果随从 X 攻击随从 Y,则攻击发生后随从 X 的生命值变为 HX - AY,随从 Y 的生命值变为 HY - AX。攻击发生后,角色的生命值可以为负数。

  本题将给出一个游戏的过程,要求编写程序模拟该游戏过程并输出最后的局面。

输入格式

  输入第一行是一个整数 n,表示操作的个数。接下来 n 行,每行描述一个操作,格式如下:

   …

  其中表示操作类型,是一个字符串,共有 3 种:summon表示召唤随从,attack表示随从攻击,end表示结束回合。这 3 种操作的具体格式如下:

  * summon :当前玩家在位置召唤一个生命值为、攻击力为的随从。其中是一个 1 到 7 的整数,表示召唤的随从出现在战场上的位置,原来该位置及右边的随从都将顺次向右移动一位。

  * attack :当前玩家的角色攻击对方的角色 。是 1 到 7 的整数,表示发起攻击的本方随从编号,是 0 到 7 的整数,表示被攻击的对方角色,0 表示攻击对方英雄,1 到 7 表示攻击对方随从的编号。

  * end:当前玩家结束本回合。

  注意:随从的编号会随着游戏的进程发生变化,当召唤一个随从时,玩家指定召唤该随从放入战场的位置,此时,原来该位置及右边的所有随从编号都会增加 1。而当一个随从死亡时,它右边的所有随从编号都会减少 1。任意时刻,战场上的随从总是从1开始连续编号。

输出格式

  输出共 5 行。

  第 1 行包含一个整数,表示这 n 次操作后(以下称为 T 时刻)游戏的胜负结果,1 表示先手玩家获胜,-1 表示后手玩家获胜,0 表示游戏尚未结束,还没有人获胜。

  第 2 行包含一个整数,表示 T 时刻先手玩家的英雄的生命值。

  第 3 行包含若干个整数,第一个整数 p 表示 T 时刻先手玩家在战场上存活的随从个数,之后 p 个整数,分别表示这些随从在 T 时刻的生命值(按照从左往右的顺序)。

  第 4 行和第 5 行与第 2 行和第 3 行类似,只是将玩家从先手玩家换为后手玩家。

样例输入

8

summon 1 3 6

summon 2 4 2

end

summon 1 4 5

summon 1 2 1

attack 1 2

end

attack 1 1

样例输出

0

30

1 2

30

1 2

样例说明

  按照样例输入从第 2 行开始逐行的解释如下:

  1. 先手玩家在位置 1 召唤一个生命值为 6、攻击力为 3 的随从 A,是本方战场上唯一的随从。

  2. 先手玩家在位置 2 召唤一个生命值为 2、攻击力为 4 的随从 B,出现在随从 A 的右边。

  3. 先手玩家回合结束。

  4. 后手玩家在位置 1 召唤一个生命值为 5、攻击力为 4 的随从 C,是本方战场上唯一的随从。

  5. 后手玩家在位置 1 召唤一个生命值为 1、攻击力为 2 的随从 D,出现在随从 C 的左边。

  6. 随从 D 攻击随从 B,双方均死亡。

  7. 后手玩家回合结束。

  8. 随从 A 攻击随从 C,双方的生命值都降低至 2。

评测用例规模与约定

  * 操作的个数0 ≤ n ≤ 1000。

  * 随从的初始生命值为 1 到 100 的整数,攻击力为 0 到 100 的整数。

  * 保证所有操作均合法,包括但不限于:

  1) 召唤随从的位置一定是合法的,即如果当前本方战场上有 m 个随从,则召唤随从的位置一定在 1 到 m + 1 之间,其中 1 表示战场最左边的位置,m + 1 表示战场最右边的位置。

  2) 当本方战场有 7 个随从时,不会再召唤新的随从。

  3) 发起攻击和被攻击的角色一定存在,发起攻击的角色攻击力大于 0。

  4) 一方英雄如果死亡,就不再会有后续操作。

  * 数据约定:

  前 20% 的评测用例召唤随从的位置都是战场的最右边。

  前 40% 的评测用例没有 attack 操作。

  前 60% 的评测用例不会出现随从死亡的情况。

思路描述

没玩过炉石,按照考试时的规则,不轻易提交(因为考试时提交时不运行的,考试完才根据你最后的提交的代码运行测试给分)。结果愣是纠结了好久,这英雄攻击力为0零,那反伤为0,那不是可以一直攻击对方英雄了- -。最后算了直接运行,100分,好吧。。。这题字符串处理没那么多,主要是玩家的处理。

代码

#include <iostream>
#include <string>
#include <sstream>
#include <algorithm>

using namespace std;

struct Property
{
int position;
int attack;
int health;
Property(){
position = -1;
attack = 0;
health = 0;
}
Property(int p,int a,int h):position(p),attack(a),health(h){}
};

struct Player {
bool alive;
int hero;
Property helper[7];
Player():alive(true),hero(30){}
};

Property Summon(string &instruction)
{
stringstream str;
int blank = instruction.find(' ');
instruction = instruction.substr(blank + 1, instruction.size() - blank - 1);
blank = instruction.find(' ');
int number[3];
str << instruction.substr(0, blank);
str >> number[0];
str.clear();

instruction = instruction.substr(blank + 1, instruction.size() - blank - 1);
blank = instruction.find(' ');
str << instruction.substr(0, blank);
str >> number[1];
str.clear();

instruction = instruction.substr(blank + 1, instruction.size() - blank - 1);
str << instruction;
str >> number[2];
return Property(number[0], number[1], number[2]);
}

void Attack(Player(&players)[2], int &attacker, int &defender, int &cur)
{
int attackIndex, defendIndex;
//寻找攻击者索引
for (size_t x = 0; x < 7; ++x) {
if (players[cur].helper[x].position == attacker) {
attackIndex = x;
break;
}
}
//寻找防御者索引
if (defender != 0) {
for (size_t x = 0; x < 7; ++x) {
if (players[!cur].helper[x].position == defender) {
defendIndex = x;
break;
}
}
}
else defendIndex = -1;
//实施攻击
players[cur].helper[attackIndex].health -= (defendIndex == -1) ? 0 : players[!cur].helper[defendIndex].attack;
if (defendIndex == -1) {
players[!cur].hero -= players[cur].helper[attackIndex].attack;
}
else {
players[!cur].helper[defendIndex].health -= players[cur].helper[attackIndex].attack;
//cout << "?->" << players[!cur].helper[defendIndex].health << endl;
}
//检测伤亡情况
if (players[cur].helper[attackIndex].health <= 0) {
//攻击方随从死亡
for (size_t x = 0; x < 7; ++x) {
if (players[cur].helper[x].position > players[cur].he
c147
lper[attackIndex].position) {
players[cur].helper[x].position -= 1;
}
}
//位置为-1表示死亡
players[cur].helper[attackIndex].position = -1;
}
if (defendIndex != -1 && players[!cur].helper[defendIndex].health <= 0) {
//防守方随从死亡
for (size_t x = 0; x < 7; ++x) {
if (players[!cur].helper[x].position > players[!cur].helper[defendIndex].position) {
players[!cur].helper[x].position -= 1;
}
}
players[!cur].helper[defendIndex].position = -1;
}
else if (defendIndex == -1 && players[!cur].hero <= 0) {
//防守方头领死亡
players[!cur].alive = false;
}
}

void processInstruction(Player(&players)[2], int &cur, string &instruction)
{
stringstream str;
if (instruction[0] == 's') {//召唤随从
Property tmp = Summon(instruction);
size_t index;
for (index = 0; index < 7; ++index)
if (players[cur].helper[index].position == -1) {
break;
}
//右边的右移
for (size_t x = 0; x < 7; ++x) {
if (players[cur].helper[x].position >= tmp.position)++players[cur].helper[x].position;
}
players[cur].helper[index] = tmp;
}
else if (instruction[0] == 'a') {//攻击
int attacker, defender;
str.clear();
str << instruction[7];
str >> attacker;
str.clear();
str << instruction[9];
str >> defender;
Attack(players, attacker, defender, cur);
}
else if (instruction[0] == 'e') {//结束回合
cur = !cur;
}
}

void DiplayHelper(Player(&players)[2], int cur)
{
int index = 1, count = 0;
for (size_t x = 0; x < 7; ++x) {
if (players[cur].helper[x].position != -1)++count;
}
cout << count << " ";
while (index <= 7) {
bool flag = false;
for (size_t x = 0; x < 7; ++x) {
if (players[cur].helper[x].position == index) {
cout << players[cur].helper[x].health << " ";
flag = true;
break;
}
}
if (!flag)break;
++index;
}
cout << endl;
}

void DisplayRet(Player (&players)[2])
{
//结果
if (players[0].alive && !players[1].alive)cout << "1" << endl;
else if (players[1].alive && !players[0].alive)cout << "-1" << endl;
else cout << "0" << endl;
//先手玩家卡牌情况
cout << players[0].hero << endl;
DiplayHelper(players, 0);
//后手玩家卡牌情况
cout << players[1].hero << endl;
DiplayHelper(players, 1);
}

int main()
{
//0是先手,1是后手
Player players[2];
int n, cur = 0;
string instruction;
cin >> n;
++n;
while (n--) {
getline(cin, instruction);
processInstruction(players, cur, instruction);
}
DisplayRet(players);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: