您的位置:首页 > 其它

PTA家谱处理

2018-03-11 14:35 1106 查看
人类学研究对于家族很感兴趣,于是研究人员搜集了一些家族的家谱进行研究。实验中,使用计算机处理家谱。为了实现这个目的,研究人员将家谱转换为文本文件。下面为家谱文本文件的实例:
John
Robert
Frank
Andrew
Nancy
David


家谱文本文件中,每一行包含一个人的名字。第一行中的名字是这个家族最早的祖先。家谱仅包含最早祖先的后代,而他们的丈夫或妻子不出现在家谱中。每个人的子女比父母多缩进2个空格。以上述家谱文本文件为例,
John
这个家族最早的祖先,他有两个子女
Robert
Nancy
Robert
有两个子女
Frank
Andrew
Nancy
只有一个子女
David


在实验中,研究人员还收集了家庭文件,并提取了家谱中有关两个人关系的陈述语句。下面为家谱中关系的陈述语句实例:
John is the parent of Robert
Robert is a sibling of Nancy
David is a descendant of Robert


研究人员需要判断每个陈述语句是真还是假,请编写程序帮助研究人员判断。


输入格式:

输入首先给出2个正整数N(2)和M(≤),其中N为家谱中名字的数量,M为家谱中陈述语句的数量,输入的每行不超过70个字符。

名字的字符串由不超过10个英文字母组成。在家谱中的第一行给出的名字前没有缩进空格。家谱中的其他名字至少缩进2个空格,即他们是家谱中最早祖先(第一行给出的名字)的后代,且如果家谱中一个名字前缩进k个空格,则下一行中名字至多缩进k+2个空格。

在一个家谱中同样的名字不会出现两次,且家谱中没有出现的名字不会出现在陈述语句中。每句陈述语句格式如下,其中
X
Y
为家谱中的不同名字:
X is a child of Y
X is the parent of Y
X is a sibling of Y
X is a descendant of Y
X is an ancestor of Y


输出格式:

对于测试用例中的每句陈述语句,在一行中输出
True
,如果陈述为真,或
False
,如果陈述为假。


输入样例:

6 5
John Robert Frank Andrew Nancy DavidRobert is a child of John
Robert is an ancestor of Andrew
Robert is a sibling of Nancy
Nancy is the parent of Frank
John is a descendant of Andrew


输出样例:

True
True
True
False
False
#include<iostream>
#include<string>
#include<cstring>
#include<vector>
#include<map>
#include<unordered_map>
#include<set>
#include<unordered_set>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstdio>
#include<ctime>
#include<list>
#include<functional>
//#include<bits/stdc++.h>
#define FIN freopen("input.txt","r",stdin)
#define FOUT freopen("output.txt","w",stdout)
#define CLOSEIN fclose(stdin)
#define CLOSEOUT fclose(stdout)
using namespace std;
const string last("null");//祖先的父亲为NULL
int main() {
vector<string> space(1005);//第i个位置存此时有i个空格的名字
unordered_map<string, string> mp;//key的父亲为values,无序map
int n, m;
cin >> n >> m;
getchar();
while (n--) {
string s;
getline(cin, s);
int num = count(s.begin(), s.end(), ' ');//计算空格数
if (num == 0) {
mp[s] = last;
space[0] = s;
}
else {
s = s.substr(num);
mp[s] = space[num - 2];//父亲为上一个少两个空格的
space[num] = s;
}
}
string T = "True", F = "False";
while (m--)
{
string a, b, c, d;
cin >> a >> d >> d >> c >> d >> b;
switch (c[0])
{
case 'p':
swap(a, b);
case 'c':
cout << (mp[a] == b ? T : F) << endl;
break;
case 's':
cout << (mp[a] == mp[b] ? T : F) << endl;
break;
case 'a':
swap(a, b);
case 'd':
while (mp[a] != b&&mp[a] != last)
a = mp[a];
cout << (mp[a] == last ? F : T) << endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: