您的位置:首页 > 其它

hdu 3974 Assign the task(dfs序+线段树)

2018-03-10 16:06 471 查看

Assign the task

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4270    Accepted Submission(s): 1746


[align=left]Problem Description[/align]There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee. 
[align=left]Input[/align]The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9) 
[align=left]Output[/align]For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line. 
[align=left]Sample Input[/align]
1
5
4 3
3 2
1 3
5 2
5
C 3
T 2 1
C 3
T 3 2
C 3 
[align=left]Sample Output[/align]
Case #1:
-1
1

[align=left]Source[/align]2011 Multi-University Training Contest 14 - Host by FZU
题意:
公司有N个人,员工有上下属关系,一共有N-1条关系。每次分配任务的时候,分发给一个员工,他和他的所有下属都会分配到该工作。有两种操作,一种是给员工x分配y的工作,另一种是查询员工x的工作是什么。
思路:
这是一种染色问题,如果单纯的用dfs来更新无疑会超时,因为可能会有链十分长的情况。所以这里用到了dfs序,dfs一次给他们都编上一个号,这样就能知道每个节点的管辖范围即为start[i]到endd[i]。
这样我们就可以用线段树来进行这个染色的问题了。注意在更新的时候也要pushdown,因为染色是即时覆盖的。
代码:#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn=50005;
vector<int> g[maxn];
int start[maxn],endd[maxn];
int used[maxn];
int tr[maxn<<2],col[maxn<<2];
int tot;
void init()
{
memset(g,0,sizeof(g));
memset(used,0,sizeof(used));
tot=0;
}
void dfs(int i)
{
tot++;
start[i]=tot;
for(int j=0;j<g[i].size();j++)
{
dfs(g[i][j]);
}
endd[i]=tot;
}
void pushdown(int i)
{
if(col[i]!=-1)
{
tr[i*2]=tr[i*2+1]=col[i];
col[i*2]=col[i*2+1]=col[i];
col[i]=-1;
}
}
void build()
{
memset(tr,-1,sizeof(tr));
memset(col,-1,sizeof(col));
return;
}
void update(int i,int l,int r,int x,int y,int c)
{
if(x<=l&&r<=y)
{
col[i]=c;
tr[i]=c;
return;
}
pushdown(i);//涂色问题会即时覆盖
int mid=(l+r)/2;
if(x<=mid) update(2*i,l,mid,x,y,c);
if(y>mid) update(2*i+1,mid+1,r,x,y,c);
return;
}
int query(int i,int l,int r,int pos)
{
if(l==r)
{
return tr[i];
}
pushdown(i);
int mid=(l+r)/2;
if(pos<=mid) return query(2*i,l,mid,pos);
else return query(2*i+1,mid+1,r,pos);
}
int main()
{
int t,u,v,m,n,x,y,cas=1;
char str[5];
scanf("%d",&t);
while(t--)
{
init();
printf("Case #%d:\n",cas++);
scanf("%d",&n);
for(int i=1;i<=n-1;i++)
{
scanf("%d%d",&u,&v);
g[v].push_back(u);
used[u]=1;
}
for(int i=1;i<=n;i++)
{
if(used[i]==0)
{
dfs(i);
break;
}
}
build();
scanf("%d",&m);
for(int i=1;i<=m;i++)
{
scanf("%s",str);
if(str[0]=='C')
{
scanf("%d",&x);
printf("%d\n",query(1,1,n,start[x]));
}
else
{
scanf("%d%d",&x,&y);
update(1,1,n,start[x],endd[x],y);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: