您的位置:首页 > 其它

杭电 acm 1108 最小公倍数

2018-03-09 22:12 260 查看
最小公倍数
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 63817    Accepted Submission(s): 35181

Problem Description

给定两个正整数,计算这两个数的最小公倍数。

 

Input

输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数.

 

Output

对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。

 

Sample Input

10 14

 

Sample Output

70

 

Source

 POJ 

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
int main()
{
int a,b;
while(cin>>a>>b)
{
int x=a,y=b;
if(y>x)
{
int temp=x;
x=y;
y=temp;
}
while(x%y!=0)
{
int temp=x%y;
x=y;y=temp;
}
cout<<((a*b)/y)<<endl;
}

}


辗转相除 最小公倍数等于乘积减去最大公约数
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: