您的位置:首页 > 其它

[置顶] 大数加法

2018-03-09 09:03 225 查看

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)[align=left]Problem Description[/align]I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
[align=left]Input[/align]The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 
[align=left]Output[/align]For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 
[align=left]Sample Input[/align]
21 2112233445566778899 998877665544332211 
[align=left]Sample Output[/align]
Case 1:1 + 2 = 3Case 2:112233445566778899 + 998877665544332211 = 1111111111111111110 
[align=left]Author[/align]Ignatius.L    第一次写博客就来个大数加法,可真是费了一番功夫,但无非就是模拟数学加法列竖式计算。    先用字符数组把两个加数当作字符串接收,再从最低位开始相加赋值到另一字符数组里(其实可以将较短的字符串与较长的字符串从最低位相加赋值到较长的字符串里),满十向前进一位。    不多说了,上代码自行体会。示例代码:#include <iostream>
#include <cstdio>
#include <cstring>
typedef long long ll;
using namespace std;
int main()
{
char a[1020],b[1020],c[1020];
int n,No=1;
scanf("%d",&n);
while(n--)
{
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
scanf("%s %s",a,b);
int l1=strlen(a);
int l2=strlen(b);
int t=0;
while(l1>0&&l2>0)
{
c[t]+=a[--l1]-'0'+b[--l2]-'0';
if(c[t]>=10)
{
c[t+1]+=c[t]/10;
c[t]%=10;
}
t++;
}
while(l1>0||l2>0)
{
if(l1==0&&l2!=0)
{
c[t]+=b[--l2]-'0';
if(c[t]>=10)
{
c[t+1]+=c[t]/10;
c[t]%=10;
}
}
else if(l1!=0&&l2==0)
{
c[t]+=a[--l1]-'0';
if(c[t]>=10)
{
c[t+1]+=c[t]/10;
c[t]%=10;
}
}
t++;
}
printf("Case %d:\n",No++);
printf("%s + %s = ",a,b);
for(int i=t;i>=0;i--)
{
if(i==t&&c[i]!=0)
putchar(c[i]+'0');
if(i!=t)
putchar(c[i]+'0');
}
printf("\n");
if(n!=0)printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: