您的位置:首页 > 其它

poj1003

2018-03-08 21:15 190 查看
HangooverDescriptionHow far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



InputThe input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.OutputFor each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.Sample Input1.00
3.71
0.04
5.19
0.00
Sample Output3 card(s)
61 card(s)
1 card(s)
273 card(s)
开始看到这题觉得很简单,就是(1/2)+(1/3)+...的一个求和,写的时候用了1/n,n为float型,后来直接用了1.0。
代码如下:
#include<iostream>
#include<stdio.h>
using namespace std;
int main(void)
{
double a;
double sum=0.0;
int i;
while(scanf("%lf",&a)!=EOF && a!=0.00)
{    sum=0.00;
for(i=2;sum<a;i++)
{
sum+=1.0/i;
}
cout<<i-2<<" "<<"card(s)"<<endl;
}
return 0;
}
scanf("%lf",&a)中成功读入a,返回值为1,没有成功读入返回值为0,遇到错误或者end of file返回值为EOF。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: